5

OS: SLES 12.3

Running these commands:

mkdir /foo/ramdisk
mount -t tmpfs -o size=100m tmpfs /foo/ramdisk

Creating a NFS on /foo/ramdisk produces this result when I run showmount -e <IP>:

clnt_create: RPC: Program not registered

When I remove the NFS share then showmount -e <IP> works again:

Export list for ...


Another strange fact:

When I create an NFS for /foo and I mount this NFS on another Linux/Windows PC then [on the PC where I mounted the NFS] there are no files visible in /foo/ramdisk and I am not allowed [yes, there are the correct permissions set] to write anything into the /foo/ramdisk directory.


I export the NFS with the SUSE tool yast and use these settings:

crossmnt,rw,no_root_squash,async,no_subtree_check


My question:

Isn't it allowed to export a ramdisk as NFS or what am I doing wrong?

4
  • 1
    Can you add the command(s) you run to export the NFS share from the ramdisk? May 7, 2018 at 13:40
  • @AndrewHenle I am doing it with the yast tool. These are the options crossmnt,rw,no_root_squash,async,no_subtree_check May 7, 2018 at 13:42
  • Yast is alien to me, but the RPC error sounds suspiciously like its telling you that the NFS server service is not running. May 7, 2018 at 13:52
  • @JohnBollinger Yes, Google finds only threads saying the same. But the service is running - I checked it. When I remove the share then it works again. May 7, 2018 at 13:54

1 Answer 1

7

I found the problem: I had to add to the NFS options fsid so now the full list looks like this:

fsid=1,crossmnt,rw,no_root_squash,async,no_subtree_check

The fact is yast doesn't warn here. I could fix the problem because I ran exportfs and then I got the error regarding the fsid.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .