1

I installed gsl on my Fedora 27 machine with:

sudo dnf install gsl

When I re-run this command, I get the output:

Package gsl-2.4-3.fc27.x86_64 is already installed, skipping.

But when I run:

find / -name gsl.pc

the file is not found. When I run:

find / -name 'gsl.*'

I get several hits for 'gsl.npz', but of course still no 'gsl.pc'.

When I run:

find / -name '*gsl*'

the only hits that even show a shadow of promise are:

/usr/lib64/libgsl.so.23
/usr/lib64/libgsl.so.23.0.0

Like others on this site, I'm trying to work through "21st Century C".

Thanks in advance to anyone for their help.

  • gsl.pc : /usr/lib64/pkgconfig/gsl.pc ... provided by gsl-devel – Knud Larsen May 6 '18 at 22:43
3

The gsl package is just the runtime libraries for GSL, enabling you to run already compiled programs which use the GSL. If you want to develop your own programs using the GSL, you need the gsl-devel package, therefore:

sudo dnf install gsl-devel

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.