11

I am trying to run Ubuntu 18.04 on a laptop with an AMD A12 processor and Radeon R7 graphics. I am having nothing but problems and am very discouraged with Ubuntu though I used 12.04 for years without such problems.

I have two problems that are maddening, and I will post them separately. The problems happen only on Gnome and Ubuntu on Xorg and do not happen on Wayland. However, I am told that it's best not to run Gnome on Wayland.

This problem is that the computer sometimes doesn't wake up from suspend. Well, I think it does wake up because the optical drive spins and the hard drive ticks away, but I cannot login because the lock screen is a hash of colors or a distorted background without a place to login. I cannot even ctrl- alt-F1 to get to a prompt. All input is frozen.

I am wondering if Xorg is configured correctly. I am running the Oilaf video driver which works well under Wayland so I don't know if there is a problem with Xorg and that driver.

  • May be duplicate to the question with this answer that worked for me: askubuntu.com/a/1041397/413258 – Roland Aug 20 '18 at 10:02
  • Do you use full disk encryption (LUKS) suggested by Ubuntu during fresh install? crypsetup may is waiting for a password but that fact is not visible on locked/blanked screen. Asking because of bug reports of the swap itself being encrypted creating a chicken-and-egg issue. See: bugs.launchpad.net/ubuntu/+source/linux/+bug/1774950 affecting many users. – arielf Dec 14 '18 at 6:58
2

There seems to be an issue with nouveau driver. Edit the grub file by editing it with sudo access.

sudo vim /etc/default/grub 

Add nouveau.modeset=0 to the line that says GRUB_CMDLINE_LINUX=""

Then run

sudo update-grub

Reboot after successfully updating grub file.

  • Does this mean GRUB_CMD_LINUX="nouveau.modeset=0"? – Clark Henry Mar 19 at 0:13
  • 1
    This should be the accepted answer. – Clark Henry Mar 19 at 23:22
  • Yes @ClarkHenry, you need to set GRUB_CMD_LINUX="nouveau.modeset=0" – Krishn Bera Mar 20 at 4:45
1

I think I found the answer to this at long last. It seems to be working so far, but it's just been a few days. The solution I came across is to:

sudo gdm3 -reset 

and reboot.

(Note: After the gdm3 reset, it's going to come back to a login screen that won't let you login. Don't worry about it. Reboot and it will return to the normal login screen and everything will be fine.)

  • 3
    I am receiving the prompt 'Failed to parse options: Unknown option -reset' Any idea why? – Ron Piggott Jun 19 '18 at 20:02
  • 1
    Same error as @RonPiggott – sP_ Jul 20 '18 at 18:05
  • 1
    Thanks for the suggestion. I got the error mentioned above and made a question for it: unix.stackexchange.com/questions/488037/… – acobster Dec 14 '18 at 18:38
1

I am having a very similar issue on an HP Pavilion 17-ar050wm laptop. I've tried lots of different things -- using Oilaf/Ubuntu-X bleeding-edge drivers, switching to lightdm, running gdm3 -reset -- but the only thing that seems to make a difference is whether I entered sleep by pressing the power button or by closing the laptop lid. When I just closed the lid, the screen/keyboard doesn't come back up properly about 3/4 of the time, but when I pressed the button first, it comes back up 100% of the time (so far).

So for lack of a better solution, I'm just going to try to remember to press the power button every time before I close the lid.

0

My machine had a similar issue after upgrading to Ubuntu 18.04. After closing the lid, the OS wouldn't wake up, but the backlight would come on. (Possibly unrelated: it appeared my keyboard was unresponsive as well, since toggling caps lock didn't light up the LED.)

I found a fix in my bios settings. There was a checkbox for enabling wake-up when the laptop lid is opened. It was unchecked, but checking it fixed the problem.

$ uname -r
4.15.0-21-lowlatency

$ lsb_release -r
Release:    18.04

$ lscpu
Architecture:        x86_64
Model name:          AMD PRO A10-8700B R6, 10 Compute Cores 4C+6G

$ dmidecode
BIOS Information
    Vendor: HP
    Version: N73 Ver. 01.17
    Release Date: 11/02/2016
0

In my situation:

$ uname -r
4.15.0-33-generic

$ lsb_release -r
Release: 18.04

$ lscpu
Architecture:        x86_64
CPU op-mode(s):      32-bit, 64-bit
Byte Order:          Little Endian
CPU(s):              4
On-line CPU(s) list: 0-3
Thread(s) per core:  1
Core(s) per socket:  4
Socket(s):           1
NUMA node(s):        1
Vendor ID:           GenuineIntel
CPU family:          6
Model:               55
Model name:          Intel(R) Pentium(R) CPU N3540  @ 2.16GHz
Stepping:            8
CPU MHz:             880.243
CPU max MHz:         2665,6001
CPU min MHz:         499,8000
BogoMIPS:            4331.60
Virtualization:      VT-x
L1d cache:           24K
L1i cache:           32K
L2 cache:            1024K
NUMA node0 CPU(s):   0-3
Flags:               fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology tsc_reliable nonstop_tsc cpuid aperfmperf tsc_known_freq pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 movbe popcnt tsc_deadline_timer rdrand lahf_lm 3dnowprefetch epb pti tpr_shadow vnmi flexpriority ept vpid tsc_adjust smep erms dtherm ida arat

$ sudo dmidecode | grep BIOS -A2
BIOS Information
Vendor: Acer
Version: V1.10
BIOS Revision: 0.0
Firmware Revision: 1.9

Hardware - Aser E5-511-P6CS

Solution is remove from grub $vt_handoff string.

To do this - just edit /etc/grub.d/10_linux file.

Set $vt_handoff = "1" to $vt_handoff = "0"

  • Do you mean change vt_handoff="1" to vt_handoff="0"? The way you wrote it is the syntax for a comparison, rather than assignment. Not sure if others' grub files are different, but there are multiple comparisons in mine...seems to make more sense to change the assignment toward the beginning of the file. – acobster Dec 14 '18 at 18:09
0

I have similar issues. Tried disable switchable graphics card and modified vt_handoff. None of them worked.

Then I "accidentally" fixed the problem by setting the SATA mode to be "ACHI" (was "IDE" when I installed ubuntu) in the BIOS. And it fixed the problem!

  • 1
    Instead of continuing a thread here (since there's no way for people to reply with Answers to your Answer), it'd be better to Answer this question (with the first 2 paragraphs) and then open a New Question with your 3rd paragraph. Thank you! – Jeff Schaller Oct 4 '18 at 16:56
0

I had this issue and resolved it by updating to the latest mainline kernel (4.20) from the Ubuntu published one (4.15) using the Ubuntu Kernel Update Utility (aka Ukuu).

At first I thought it might be a display driver problem, so I downgraded to nvidia-390, but it persisted. Completely disappeared after updating to 4.20 kernel though.

0

The Screen Saver helped me with Xubuntu 18.04 - except I installed xscreensaver and everything started working correctly.

0

To repair this instance, i typed:

sudo apt install gnome-screensaver

And it worked first time. I don't know why the file wasn't working or why it wasn't there, but like i said... worked for me.

protected by Community Apr 5 at 4:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.