0

On kernel version 4.15.0-sabayon, the only way to load X is with the kernel options:

acpi_osi=! acpi_osi='Windows 2009'

(and acpi=off but that's radical and leaves me with no sensors). Otherwise I get unresponsive black screen and no obvious error in the X.org log.

The problem with this option is that it turns off the Elan 1200 touchpad (not only for me, other people complain about it as well).

So I'm looking for other (if possible tested) kernel options which might work on my laptop (or similar). I've tested already many permutations of different windows versions and modeset and acpi_rev_override=5 and pcie_port_pm=off, but obviously I can't cover them all so if anyone had success with this, please share.

0

I have the same model and for me acpi_osi=! worked. Also check this out: acpi4asus Which kernel you use? For me 4.13 is working without any extra params. I have this problem with 4.15 and the newer ones.

  • Hi and thanks for stopping by. For me acpi_osi=! doesn't load X. I tried with acpi_osi=! acpi_osi='Windows 2009' acpi_asus_load="yes" and it works, but still no Elan 1200 touchpad in X. Can I ask you what is your distro and also, in your bios, do you use AHCI or Intel RST? My kernel is 4.15. – jane_xxx May 7 '18 at 13:40
  • I am on Kubuntu 18.04 and have tried this also on Manjaro. On manjaro the touchpad was working better. I use intel RST. I've seen some people using acpi_osi='Windows 2012' instead of 2009. But I haven't tested this. – Perbasilopou May 8 '18 at 10:35
0

Working on ubuntu 18.04, kernel 4.17-rc6, nvidia 396.


Fixed on latest kernel 4.17.0-rc6 using nvidia 396 (installed from ubuntu graphics ppa).

No more black screen of death, works Touchpad (except for the (five finger tap freeze), brightness (but not keys) and everything else.

I believe in a long term the solution will be merged on kernel.


NVIDIA Driver Install

Boot with acpi_osi=!, add ubuntu graphics ppa:

sudo add-apt-repository ppa:graphics-drivers/ppa sudo apt-get update

Install nvidia latest graphics (current on post 396.X).


Kernel install

Go to: http://kernel.ubuntu.com/~kernel-ppa/mainline/ and look for latest kernel. Current on answer 4.17rc6

Download for amd64: linux-headers, linux-headers-XXXXX-generic, linux-image-XXXXX-generic, linux-modules-XXXX-generic.

Leave all inside a folder. Open in bash and run sudo dpkg -i *.deb

Boot with default boot parameters. acpi_osi=! is not needed anymore.

  • Take care... this is verging on being a long comment rather than an answer. – roaima May 20 '18 at 21:58
  • Gustavo, my situation is exactly the same. I can see in the old logs that Elantech was recognised using options 2012 and 2015, but I also get a black screen. I tried various things, for example starting bumblebee after lightdm, but I still get black screen. It's just a nightmare. The idea of laptops is to be able to carry them around. It sucks not having a touchpad. – jane_xxx May 21 '18 at 14:03
  • I've found that there are aparent no errors on dmesg and Xorg logs. But the folders: /sys/class/backlight/acpi_video0/ and /sys/class/backlight/intel_backlight are missing. Using acpi_osi=! when i turn the backlight to minimum the screen turns black. – Gustavo Garcia May 22 '18 at 12:11
  • Reached the answer after lots of testing. Touchpad working now. – Gustavo Garcia May 26 '18 at 15:54
  • Gustavo, thanks for adding your solution. I'm not using Ubuntu, so I'll probably have to wait for the official Gentoo release of the 4.17 kernel. And if it's not working, I'll try installing the -r6 manually. But it's absolutely encouraging to read that at least somewhere that crappy touchpad started working. Thanks. – jane_xxx Jun 3 '18 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.