0

I have a problem with apache in (debian 9 64bit). i want to install drupal such as this article but when i want to start apche showed me this error:

mjb@debian:~$ systemctl start apache2
Job for apache2.service failed because the control process exited with error code.
See "systemctl status apache2.service" and "journalctl -xe" for details.

and i was installed NODE-RED, before apache.

the NODE-RED use this address : localhost:1880

the apache use port 80.

result of this command systemctl status apache2.service :

mjb@debian:~$ systemctl status apache2.service
● apache2.service - The Apache HTTP Server
   Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sat 2018-05-05 15:28:54 +0430; 37min ago
  Process: 1398 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILURE)

result of this command journalctl -xe :

root@debian:/home/mjb# journalctl -xe
May 05 16:09:01 debian CRON[2339]: (root) CMD (  [ -x /usr/lib/php/sessionclean ] && if [ ! -d /run/systemd/system ]; then /usr/lib/php/sessionclean; 
May 05 16:09:01 debian CRON[2338]: pam_unix(cron:session): session closed for user root
May 05 16:09:15 debian systemd[1]: Starting Clean php session files...
-- Subject: Unit phpsessionclean.service has begun start-up
-- Defined-By: systemd
-- Support: https://www.debian.org/support
-- 
-- Unit phpsessionclean.service has begun starting up.
May 05 16:09:16 debian systemd[1]: Started Clean php session files.
-- Subject: Unit phpsessionclean.service has finished start-up
-- Defined-By: systemd
-- Support: https://www.debian.org/support
-- 
-- Unit phpsessionclean.service has finished starting up.
-- 
-- The start-up result is done.
May 05 16:09:55 debian systemd[1]: Starting The Apache HTTP Server...
-- Subject: Unit apache2.service has begun start-up
-- Defined-By: systemd
-- Support: https://www.debian.org/support
-- 
-- Unit apache2.service has begun starting up.
May 05 16:09:55 debian apachectl[2399]: apache2: Syntax error on line 225 of /etc/apache2/apache2.conf: Syntax error on line 11 of /etc/apache2/sites-
May 05 16:09:55 debian apachectl[2399]: Action 'start' failed.
May 05 16:09:55 debian apachectl[2399]: The Apache error log may have more information.
May 05 16:09:55 debian systemd[1]: apache2.service: Control process exited, code=exited status=1
May 05 16:09:55 debian systemd[1]: Failed to start The Apache HTTP Server.
-- Subject: Unit apache2.service has failed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
-- 
-- Unit apache2.service has failed.
-- 
-- The result is failed.
May 05 16:09:55 debian systemd[1]: apache2.service: Unit entered failed state.
May 05 16:09:55 debian systemd[1]: apache2.service: Failed with result 'exit-code'.

EDIT:

in file /etc/apache2/sites-enabled/drupal.conf i see this :

<VirtualHost *:80>
ServerAdmin admin@example.com
DocumentRoot /var/www/html/drupal
ServerName 192.168.15.189
ServerAlias www.example.com
<<Directory "/var/www/html/drupal/">
Options FollowSymLinks
AllowOverride All
Order allow,deny
allow from all
</Directory>
ErrorLog /var/log/apache2/drupal-error_log
CustomLog /var/log/apache2/drupal-access_log common
</VirtualHost>

note : i use from node-red (localhost:1880/)

  • @Vlastimil, thanks i check it & see this in line 225 " IncludeOptional sites-enabled/*.conf " but I do not know what to put in place of the asterisk (*.conf ) – mohammad jawad Barati May 5 '18 at 13:15
  • @Vlastimil, excuse me, i don't know really what i must do. can you help me to fix it. – mohammad jawad Barati May 5 '18 at 13:34
0

There is an error in the article you have been following, on the line:

<<Directory "/var/www/html/drupal/">

Just remove one of the starting brackets <.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.