0

I have a really old laptop and no Linux so far had drivers built-in for it. I also don't have access to the router, so I can only use wifi, and I do want to be able to use wifi. So how do I get it working? I tried finding the package, but they just fail installation/don't work/require a few dozens of other packages. I only got a couple of Linux (out of over 10) booting up on it in the first place, and I did manage to get wifi working on Lubuntu awhile back when I had access to ethernet cable - took maybe 10 minutes to install all the packages (well, wait for them to be installed), but it worked after that.

The Wifi adapter is Broadcom Limited BCM4311 802.11b/g WLAN (rev 01).

6
  • Without giving the exact laptop model and the wifi chipset you won't get much help. Do you have some CDROM on that laptop? Some bootable USB port? – Basile Starynkevitch May 5 '18 at 7:15
  • Adding the output of lspci and lsusb can help determine what pieces may be required: some WiFi chipsets need binary firmware in order to function, in addition to kernel modules. With the information that you provided, the answers that you will receive will be extremely general in nature as there have no specifics to base an answer on. – ErikF May 5 '18 at 7:30
  • @ErikF Thank yo ufor the suggestion! I edited the question, and the adapter is Broadcom Limited BCM4311 802.11b/g WLAN (rev 01). – Jack May 5 '18 at 9:24
  • Please edit your question : Add the lspci -vv output relevant for "WiFi". lsusb -vv : The same. My example (ZyXEL) : $ lsusb -vv | grep -i zyxBus 002 Device 005 : ID 0586:3412 ZyXEL Communications Corp. 802.11bg ... idVendor : 0x0586 ZyXEL Communications Corp. – Knud Larsen May 5 '18 at 10:02
  • 2
    Try the b43 module : sudo modprobe -v b43 – GAD3R May 5 '18 at 10:19
3

The problem was that I needed to do this (for some reason Linux did not do this by default):

sudo nano /etc/NetworkManager/NetworkManager.conf
change the line managed=false to managed=true

Save, stop and start network manager:

sudo service network-manager restart

Took it from here after spending hours looking for a problem through info provided in my own thread (which is how I even got to the answer in the first place): https://askubuntu.com/questions/71159/network-manager-says-device-not-managed

2

I had the same problem with my oldest laptop, in order to solve the problem I recommend using Debian distribution or a flavour of it. Debian maintains plenty of devices' drivers, and on Debian wiki you can find a complete solution for bcm43xx network family card. Plus, on Ubuntu-forum, a user has provided a comprehensive solution to overcome the issue.

2

Take out the harddisk of the laptop, connect harddisk to another computer with a working wifi, install some distribution with all the necessary drivers on it, put harddisk back in laptop, boot.

Alternatively: Prepare an USB stick with a live distribution which has all the necessary drivers, boot from USB stick (unless your laptop is really old, and can't boot from USB sticks).

-1

You can install from DVD and install "firmware-iwlwifi_20161130-4~deb8u1_all.deb", or as mentioned above, put hard drive in another computer, select expert install and select to install all drivers. Since I dont like non-free firmware that I can not compile myself, I found it easier to buy a wifi card from ebay that debian had already included in their DVD ios for $3.99

3
  • Welcome, As said it is a Broadcom wifi card not Intel. – GAD3R Dec 15 '18 at 18:53
  • debian has packages for b43xx and b43legacy (wiki.debian.org/bcm43xx#supported-b43) if all fails, there is a possibility that your hardware is bad. As I said, I had some what of a similar issue. Spent 2 days research and 1 migraine later, I bought a used card from ebay. $3.99 later, problem was fixed on boot. I wish "i had a better answer for you, – user741162 Dec 15 '18 at 19:53
  • 1
    firmware-iwlwifi provide the drivers for Intel wifi card. The last line in the question say it is a Broadcom wifi card. As you can see in the accepted answer it is not a driver problem. – GAD3R Dec 15 '18 at 19:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.