I installed a clean version of Manjaro. When I boot up, I make it all the way to the log in screen. When I enter my password, the login prompt disappears and I get the Manjaro background with a cursor. I can move the cursor but nothing else. Nothing comes up and it stays on this screen forever.

Before logging in I’ve tried the Ctrl+F2 then Ctrl+F7 thing, but when I do Ctrl+F7 the screen freezes and I can’t move the mouse or anything. Please help, I’ve been having this problem for a while and I’ve never logged into the system yet.

I have an Nvidia Graphics Card and Core i7 processor. It is running Xfce

  • Does right-clicking on the desktop bring up anything?
    – Kusalananda
    May 4, 2018 at 19:04
  • Write a bugreport May 4, 2018 at 19:33
  • No it does not.
    – blacKnight
    May 4, 2018 at 19:34
  • How long did you wait after entering your password? Is your system able to access your network, and did you configure a DNS nameserver?
    – L.Ray
    May 4, 2018 at 19:54
  • @blacKnight I faced a similar issue, it is an annoyance but easily fixable assiming it is the same problem: 1. try to connect another monitor on the HDMI port maybe your main screen is outputted there. Also read: unix.stackexchange.com/questions/320642/…
    – vfbsilva
    May 4, 2018 at 20:14

2 Answers 2


I've had the same issue on Manjaro after upgrading everything post fresh install. My initial fix was to delete the displays.xml file found in ~/.config/xfce4/xfconf/xfce-perchannel-xml/ folder. Problem is, anytime you go to your display manager or update Manjaro, it'll recreate the file and thus the problem will persist.

So it turns out, from what my research has gathered, that the xfce4 displays.xml config file was likely conflicting with something in xorg.conf: the refresh rate.

Now I'm not sure if this was from the display vender info for my monitor (Samsung 22" LED) or bundled with xorg/X11 or with the nvidia display drivers...or somewhere else.

All I know is this worked for me (FIX HERE--->): In Manjaro, in the panel menu, search for "Display", open it (the Display manager), change the Refresh Rate pulldown menu option from 60Hz to 59.9Hz and click "Apply". This solved the problem for me. I rebooted and confirmed my problem was solved.

So I think this issue may exist with certain hardware/monitor combinations whenever Manjaro/XFCE/Kernel/GPU Drivers are updated via Manjaro's repository. Tested same exact hardware with Linux Mint 19 Tara XFCE and could not replicate this issue. I'm still fairly new to Manjaro and not exactly sure what the conflict is or where it originates, but it only happens after I am fully finished upgrading kernel/display driver (Nvidia Nonfree) does this happen on a reboot/logout. I am fairly certain it has to do with the refresh rate settings themselves not jiving.


I think I found the solution for my case for this exact problem after facing it for 3 months!. Read on!


  • Laptop with Intel HD integrated graphics (No dual GPU, no Nvidia Optimus)
  • Manjaro with KDE Plasma

Problem description:

  • After fresh install of Manjaro and attempt to login with your password on the Login page, the screen freezes
  • Even if you manage to pass by some miracle after the Login page (after many restarts and tries) some programs will simply start and instantly "hide" on launch. You are unable to start 90% of the applications.

Factors which seem to be involved:

It seems like the problem is caused by a combination of the following factors: - Your GPU model (Intel Integrated Graphics only in my case, without other GPUs for Nvidia Optimus technology - aka swapping between integrated and dedicated graphics) - Your choice whether to use a free or non-free GPU driver in Manjaro - Your Desktop Environment of Choice (In my case: KDE) - Kernel version (I tried all kernels 4.15-4.19. Only 4.20 worked)

Things which I tried and did not work:

  • Tried both free and non-free GPU drivers
  • Tried every major Manjaro distro version from 2015 until 2019. Did not work
  • Stable kernel versions (I tried all kernels 4.15-4.19)
  • Reinstalling Xorg, packages, messing around with various Xorg configurations
  • Full upgrade of all packages

Things which worked by bypassing the problem:

  • Updating to Kernel 4.20 (You can do this from "System settings > Kernel"). Good thing about updating the kernel is that it will fix your GRUB if you have messed it.
  • Booting Manjaro with with the following boot options (in order to do this press "e" while at the GRUB menu and then find the parameter "quiet" somewhere in the bottom and add the following parameters after it):

i915.modeset=1 vga=791

Basically, what this does is if you have an Intel based GPU, it forces graphical parameters to be run before X server starts and setting your resolution to 1024x768x32 which is widely supported by most systems. Using this trick you should be able to bypass the "blank black screen" bug, which happens when X server is not able to compose your screen. If you add the parameter


(yes, just the number 3) as a parameter after "quiet" this will boot your system entirely in text mode. - TIP: If you boot your Manjaro and in the login screen you hit CTRL+ALT+F3, enter your username and password and then enter "sudo startx" the system is able to "bypass" the login freeze. However, you will be logged in as the "root" user and you will have limited access to most programs.

Effective solution:

  • Update your kernel to 4.20
  • Do full system upgrade with:

sudo pacman -Syyu

  • Disable and uninstall your GPU drivers in "Hardware Detection Tool"
  • Change your Software rendering setting by going to:

Settings > Display and Monitor > Compositor > Rendering backend > OpenGL 3.1

  • Restart

In case you still get a "black blank screen" after you do these, boot Manjaro with boot options into text mode (already described how above), and try re-installing your GPU drivers again via the guide here: https://wiki.manjaro.org/index.php/Configure_Graphics_Cards#Automated_Identification_and_Installation

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .