1

I downloaded Emacs in Linux 14.04, and when I type emacs filename.c, it opens Emacs in the terminal instead of the external Graphical User Interface. How do I force Emacs to open outside of the terminal?

  • Does your user account has permission to open the file? Have you tried sudo emacs filename.c? – Paulo Tomé Dec 13 '19 at 15:48
1

For Emacs in a GUI type:

emacs -c

For an Emacs client in a GUI using a daemon:

emacs --daemon

emacsclient -c 
|improve this answer|||||
  • 1
    Emacs does not have a -c option by default. – jirassimok Nov 25 '19 at 2:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.