1

I'm having a really weird issue with oVirt. I download ISOs, and they'll work for about ~3 boots, and then they just start kernel panic'ing out of nowhere. The error is as follows:

Kernel panic - not syncing: No init found. Try passing init= option to kernel.

Removing quiet doesn't add more visible debug info.

This has so far happened on around five different downloads of CentOS. I've verified the checksum of the ISO with the one provided on the CentOS website, and it's fine. Everything is hosted in an ISO domain, as an NFS share. Unfortunately, this happens with Glance templates as well, mainly CentOS. Debian Buster worked the first time, after a couple other ISOs failed, but I haven't repeatedly tried it.

I'm running on the latest oVirt version (4.2.2), with the hosted engine, and this only started after updating from 4.2.0.

Thanks in advance!

  • How much memory is being allocated to the VM? – dsstorefile1 May 3 '18 at 3:54
  • I hate life. Is it possible to delete your own brain? You're right, it was RAM. Apparently, I can't tell the difference between max mem and alloc mem. – Eamonn Nugent May 3 '18 at 3:57
2

As it turns out, courtesy of @dsstorefile1, it was memory!

To anyone that sees this, maximum meory size is not the allocated memory. It's a hot plug thingy. Use the first option.

I'm an idiot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.