3

I have been trying to install GUI, i.e. gnome and lxde, into Debian 9 stretch in google cloud computing instance. I have even increased the cpu, ram, harddisk size. However, the installation is always stuck at "Setting up dbus (1.10.26-0+deb9u1)"

My last attempt is letting it sit for 6 hours now. It's still stuck there.

What can I do?

Thanks and Regards

Edit1: I found this line. Does this have to do with this error?

Setting up rtkit (0.11-4+b1) ...
Created symlink /etc/systemd/system/graphical.target.wants/rtkit-daemon.service → /lib/systemd/system/rtkit-daemon.service.
Job for rtkit-daemon.service failed because a timeout was exceeded.
See "systemctl status rtkit-daemon.service" and "journalctl -xe" for details.
rtkit-daemon.service couldn't start.

Edit2: I shutdown the instance and get thefollowing. Not sure if this may mean anything or not related at all - again because I forced shutdown the system.

Setting up dbus (1.10.26-0+deb9u1) ...
Job for dbus.service canceled.
invoke-rc.d: initscript dbus, action "start" failed.
● dbus.service - D-Bus System Message Bus
   Loaded: loaded (/lib/systemd/system/dbus.service; static; vendor preset: enabled)
   Active: failed (Result: exit-code) since Wed 2018-05-02 21:38:17 UTC; 31min ago
     Docs: man:dbus-daemon(1)
 Main PID: 15748 (code=exited, status=1/FAILURE)
May 02 21:37:52 instance-2 systemd[1]: Started D-Bus System Message Bus.
May 02 21:37:52 instance-2 dbus-daemon[15748]: Failed to start message bus: Could not get UID and GID for username "messagebus"
May 02 21:38:17 instance-2 systemd[1]: dbus.service: Main process exited, code=exited, status=1/FAILURE
May 02 21:38:17 instance-2 systemd[1]: dbus.service: Unit entered failed state.
May 02 21:38:17 instance-2 systemd[1]: dbus.service: Failed with result 'exit-code'.
dpkg: error processing package dbus (--configure):
 subprocess installed post-installation script returned error exit status 1

bumped to the homepage by Community 2 days ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

  • got the same problem, fresh clean debian installation followed by lxde install, hangs at the same line with the same previous error about rtkit. installed within virtualbox. – ulkas May 16 '18 at 21:07
0

i was able to complete the installation by first installing the dbus library alone, and just after proceeded with the lxde installation:

sudo apt-get install dbus
sudo apt-get install lxde
0

Restart your server and then do

dpkg --configure -a

happen to me always when i setup vnc it stuck and then have to restart vps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.