5

I tried to setup a LEMP stack over Alpine GNU/Linux Distribution running on a VM WITHOUT docker.

Then I tried to install the php7-mysqli over via community repositories with:

sudo apk add php7-mysqli

But I got the following errors:

ERROR: unsatisfiable constraints:
  so:libcrypto.so.43 (missing):
    required by: php7-openssl-7.2.5-r0[so:libcrypto.so.43] php7-openssl-7.2.5-r0[so:libcrypto.so.43]
  so:libssl.so.45 (missing):
    required by: php7-openssl-7.2.5-r0[so:libssl.so.45] php7-openssl-7.2.5-r0[so:libssl.so.45]

I have installed libressl but the errror still persists. Any idea why that happens? Keep in mind I have set to the repositories to the community's one:

http://dl-2.alpinelinux.org/alpine/edge/community

Edit 1:

I followed the instructions mentioned in https://www.cyberciti.biz/faq/how-to-install-php-7-fpm-on-alpine-linux/

Edit 2:

I tried to install libressl2.6-libcrypto-2.6.3-r0 via the following command:

sudo apk add libressl2.6-libcrypto-2.6.3-r0

And I got the following output:

ERROR: unsatisfiable constraints:
  libressl2.6-libcrypto-2.6.3-r0 (missing):
    required by: world[libressl2.6-libcrypto-2.6.3-r0]

If I try to install the libressl package I get the following response:

sudo apk add libressl
(1/2) Installing libressl2.6-libtls (2.6.3-r0)
(2/2) Installing libressl (2.6.3-r0)
Executing busybox-1.27.2-r8.trigger
OK: 119 MiB in 53 packages

And the problem still remains.

Also the I tried to install libressl2.7-libcrypto via:

sudo apk add libressl2.7-libcrypto

And I got the following errors:

ERROR: unsatisfiable constraints:
  libressl2.7-libcrypto (missing):
    required by: world[libressl2.7-libcrypto]

3 Answers 3

4

You need to install:

libressl2.7-libcrypto

That package provides both of the files that are missing.

1
  • I tries to install it via sudo apk add libressl2.7-libcrypto and I got some errors. I updated the initial post in order to have an easy to read and complete way of my steps. Commented May 3, 2018 at 20:56
2

The answer from Nasir Riley is good but you also have to change your /etc/apk/repositories to replace v3.7 to edge that's the first file I change if I want to use latest edge Alpine.

After that you can install libressl2.7-libcrypto as usual.

0

To install the library with a single command:

apk add libressl3.1-libcrypto --repository http://dl-3.alpinelinux.org/alpine/edge/main/ --allow-untrusted

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .