3

so I am trying to upload my package that I compiles and build on a machine running 18.04 to Bintray.

It doesn't work. I get a message like this:

Unable to upload files: Could not extract metadata for artifact 'pool/m/myapp/myapp_1.0~bionic1_amd64.deb', content might be malformed.

I tried installing the package and no issues with that. I also tried getting the package information using:

dpkg-deb --build myapp_1.0~bionic1_amd64.deb

and no problem with that either.

This is the command I use to build the package:

dpkg-deb --build myapp_1.0~bionic1_amd64

If I build the package using 16.04 (booted off LiveDVD) and ran the same command, I can upload the .deb without any issues.

I've tried 1 other repo (cannot remember the exact site but it starts with "gem") and I get the same error.

Any ideas on what I could be doing wrong and how to fix it?

Thank

3

I am not sure, but Ubuntu 18.04 use dpkg 1.19.0, which use per default uniform compression. Maybe Travis CI doesn't support it.

--[no-]uniform-compression

Specify that the same compression parameters should be used for all archive members (i.e. control.tar and data.tar; since dpkg 1.17.6). Otherwise only the data.tar member will use those parameters. The only supported compression types allowed to be uniformly used are none, gzip and xz. The --no-uniform-compression option disables uniform compression (since dpkg 1.19.0). Uniform compression is the default (since dpkg 1.19.0).

0

The difference is indeed in the compression used in the control part of the package:

$ ar t example.deb # 16.04
debian-binary
control.tar.gz
data.tar.xz

$ ar t example.deb # 18.04
debian-binary
control.tar.xz
data.tar.xz

Bintray still doesn't support packages created on Ubuntu 18.04.

It is possible to workaround this issue by specifying options to dh_builddeb in the debian/rules file:

override_dh_builddeb:
        dh_builddeb -- --no-uniform-compression
0

This feature would be welcome in bintray?

I pinged them at: https://github.com/travis-ci/travis-ci/issues/9656

Stay tuned

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.