Have CentOS 6.2. I'm trying to install Audacity, and I'm getting package problems. The Audacity webpage says I need the wxWidgets library, which I think I've installed correctly (./configure, make, and make install seemed to go through ok.) I also think I've installed the libsndfile library correctly.


  1. Is wxWidgets the same as wxGTK?
  2. Why does the Audacity install (using yum) still seem to think I need the packages, if the installs appear to have gone through correctly?
  3. Is there a nicer way to do this? I want to do something like type "Install Audacity", and some package manager finds all required packages and installs them automatically. I do not want to have to hunt down a raft of packages to install a simple program!

wxWidgets is a cross-platform GUI library. wxGTK is the Linux implementation of wxWidgets on top of the GTK library (there are others, such as wxMotif on top of Motif).

Since you've installed wxWidgets manually from source, it is not known to the package manager. Only packages installed with the rpm command (or commands that call it, such as yum) are known to the package manager.

It's unusual for repositories to provide a program without its dependencies. If you have a package source that includes Audacity, I'd expect that either it contains the necessary libraries, or the necessary libraries are in the official distribution.

CentOS is a rather conservative distribution. It doesn't have as many packages as other desktop or server distributions. If you want to have a lot of packages, get something like Debian or Ubuntu or Fedora or Gentoo; I recommend Ubuntu as the most user-friendly.

  • Would a force install work? That is, would Audacity be able to tell that I've installed wxWidgets, even though it wasn't in a package? I hear you about Ubuntu, and I've thought about it. But I was interested in the stability of CentOS for the particular computer on which I've installed it. – Adrian Keister Jul 28 '12 at 17:26
  • @AdrianKeister rpm --nodeps would work, assuming you installed the same version of wxWidgets that this Audacity binary was compiled with. But, again, when a repository provides a program, it usually provides the necessary libraries too, unless they're in the standard distribution or in some other repository that should be mentioned in the repository's description. – Gilles Jul 28 '12 at 17:42
  • I think it's so messed up now that I'm just going to go with Ubuntu, like you said. I'll have to learn CentOS on a different machine, I suppose. Thanks for your help! – Adrian Keister Jul 28 '12 at 18:44
  • Ubuntu was a breeze. I spent less time installing the entire operating system plus Audacity than I spent wrestling with CentOS trying to install Audacity. I'm not giving up on CentOS completely, though. I'll have to look into it maybe for RH certs. Thanks again for all the help! – Adrian Keister Jul 30 '12 at 23:31

If you are looking for a simple yum install audacity, than you need to enable the rpmforge repository.


  • This was a good thought, but unfortunately, it didn't work for Audacity. Everything installed fine, but then when I tried the yum install audacity command, it said it couldn't find the package audacity, and there was nothing to do. I even tried with more specific names of the audacity packages available at rpmforge, and that didn't work, either. Suggestions? – Adrian Keister Jul 28 '12 at 17:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.