1

snd_hda_intel audio driver is not loading

I recently installed debian9 stretch on my acer 14 CB3-431 chromebook.

Here is the link of this iso I used: firmware-9.4.0-amd64-netinst.iso

I did fresh install of stretch to sid in order to install: firmware-linux-nonfree and avoid driver problems I had in previous installations.

However, sound and microphone are not working on my machine. I checked what audio chip my chromebook used:

 luka@chromebook:~$ sudo dmesg | grep audio
 [    5.162184] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops 
 i915_audio_component_bind_ops [i915])

I looked up on intel website the driver but didn't find it. I also used alsamixer and checked that all channels of my audio card were not muted and configured with sufficient volume to produce sound. Sound still doesn't work.

This shows that my audio chip is enabled:

luka@chromebook:~$ amixer
Simple mixer control 'Master',0
Capabilities: pvolume pswitch pswitch-joined
Playback channels: Front Left - Front Right
Limits: Playback 0 - 65536
Mono:
Front Left: Playback 65536 [100%] [on]
Front Right: Playback 65536 [100%] [on]
Simple mixer control 'Capture',0
Capabilities: cvolume cswitch cswitch-joined
Capture channels: Front Left - Front Right
Limits: Capture 0 - 65536
Front Left: Capture 65536 [100%] [on]
Front Right: Capture 65536 [100%] [on]

I searched for the driver on my machine:

luka@chromebook:~$ locate i915
/lib/firmware/i915
/lib/firmware/i915/bxt_dmc_ver1.bin
/lib/firmware/i915/bxt_dmc_ver1_07.bin
/lib/firmware/i915/bxt_guc_ver8_7.bin
/lib/firmware/i915/bxt_huc_ver01_07_1398.bin
/lib/firmware/i915/kbl_dmc_ver1.bin
/lib/firmware/i915/kbl_dmc_ver1_01.bin
/lib/firmware/i915/kbl_guc_ver9_14.bin
/lib/firmware/i915/kbl_huc_ver02_00_1810.bin
/lib/firmware/i915/skl_dmc_ver1.bin
/lib/firmware/i915/skl_dmc_ver1_23.bin
/lib/firmware/i915/skl_dmc_ver1_26.bin
/lib/firmware/i915/skl_guc_ver1.bin
/lib/firmware/i915/skl_guc_ver4.bin
/lib/firmware/i915/skl_guc_ver6.bin
/lib/firmware/i915/skl_guc_ver6_1.bin
/lib/firmware/i915/skl_huc_ver01_07_1398.bin
/lib/modules/4.15.0-3-amd64/kernel/drivers/gpu/drm/i915
/lib/modules/4.15.0-3-amd64/kernel/drivers/gpu/drm/i915/i915.ko
/lib/modules/4.9.0-6-amd64/kernel/drivers/gpu/drm/i915
/lib/modules/4.9.0-6-amd64/kernel/drivers/gpu/drm/i915/i915.ko
/usr/lib/x86_64-linux-gnu/dri/i915_dri.so

It seems the driver is installed but not loading or working. How can I fix my sound and microphone problem?

4
1

Recommended solution: Gallium OS

I solved the problem changing to Gallium OS, based xubuntu and specially designed for chromebooks. Sound and microphone are now working.

Here is a link to their website: https://galliumos.org

Installing a kernel

If you encounter the same problem and don't want to change OS, I suggest installing one of the latest kernels at this page:

https://www.kernel.org

  1. Firstly, you can install the tarball and extract it using tar.

  2. Then, you would need to build the kernel manually with:

    make localmodconfig make -jnproc deb-pkg

  3. Finally, you will need to install all deb packages with dpkg -i

I would personally download this kernel: stable: 4.16.5 as it is modern enough. I didn't choose that option because I only have 4GB RAM and a poor 1.60Ghz processor (one core). This option is risky in my case; overheating could brick my computer.

Buying a sound USB

Another option would be to buy a sound USB and plug a speaker on it. You can find cheap ones on amazon.

0

From your hatebin link, I see you have not one but two sound "cards" (actually integrated chips) in your system.

It appears that snd_hda_intel has one codec module associated with it: snd_hda_codec_hdmi. This means it's probably connected to the HDMI output only, and has no microphone inputs as a result.

The other sound chip is apparently named something like snd_soc_sst_atom_hifi2_platform or possibly snd_soc_rt5645, I'm not quite sure which of those is the main module for that sound chip.

Please run cat /proc/asound/cards to see a list of detected sound chips and the numbers assigned to each sound chip. Then you can use alsamixer -c <number> to adjust the mixer of each chip. By default, alsamixer only picks the first chip detected, or possibly PulseAudio if it's active.

2
  • I do have two integrated chips and configured them using alsamixer with F2 option. However, this didn't fix the problem as I wrote. The easiest solution is to install gallium OS, xubuntu based and designed for chromebook hardware. – Luka Lafaye de Micheaux Apr 30 '18 at 8:09
  • That's indeed probably the best solution for your hardware. I hope my answer might be useful for someone else with a similar problem on different hardware. – telcoM Apr 30 '18 at 8:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.