0

I have a connection between two datacenters and rsync between them stalls often. I think it is related to the mtu 9000 (I actualy set it to 8900 because of some possible vlan use)

I have the impression that the icmp mtu 8900 is working, but that tcp traffic is having sometimes problems with big frames.

Has any one experienced something similar? And how do you test MTU 8900 with just a tcp test?

PS. I don't have control over this connection

  • Jumbo frames are only supposed to be used in a network where all the NICs are operating at jumbo frames, and mostly for a LAN network. – Rui F Ribeiro Apr 28 '18 at 18:54
  • Have you tried reducing the MTU to see if the issue goes away? And/or have you tried doing a tcpdump on both sides when the issue is occurring to see if packets are making it through? – Patrick Apr 28 '18 at 19:39
  • 1
    On a few *NIXes (Linux, some *BSD) it should even be possible to lower the MSS (which usually derives from MTU) for TCP without changing the jumbo frame settings: with iptables + TCPMSS on Linux, and pf + scrub max-mss on *BSD. – A.B Apr 28 '18 at 20:13
  • 1
    @RuiFRibeiro, it is configured like this – f1 outsourcing May 2 '18 at 8:01
  • 1
    @f1outsourcing If dropping the MTU fixed it, then yes, you should definitely do a packet capture. This smells like you have something in the mix which is dropping ICMP packets, which are critical to the operation of networks, especially when you have oversized frames. – Patrick May 2 '18 at 11:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.