0

Operating system: debian 9, varnish version: 5.0.0

I have turned off IPv6 support on my machine and varnish crashes upon start with the following error:

Error: Cannot open socket: :6081: Address family not supported by protocol

I know this question has been asked here here, but it does not solve my problem. Also, I can't find any IP-related configuration option in the config files.

So, how can I run varnish cache without IPv6 support?

  • how exactly did you turn off IPv6? – thrig Apr 27 '18 at 13:46
1

By default, the main listen address/port is specified in the DAEMON_OPTS variable in /etc/default/varnish file as -a :6081, which means both IPv4 and IPv6, port 6081.

Try explicitly specifying an IPv4 listen address with the port: for example, if your system's IP address is 192.168.100.1, edit the address/port option to -a 192.168.100.1:6081.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.