-1

Can`t upgrade ubuntu to newest version, get this errors: while update manager starts

while press Continue

I tried to fix the errors through Synaptic, but the program did not see the broken packages. I also tried to fix errors using the terminal command, but it did not help

    $ sudo apt-get install -f
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

so how to fix this strange error?

1

The first thing to to is to run on a terminal:

# apt-get update

# apt-get dist-upgrade

The output from the upgrade could give a bit more information about what has happened.

If the issue does not get resolved by dist-upgrade then you might have a problem in your source.list files. In that case, we need to know what is in them, so you need to share what's in the /etc/apt/sources.list file and also what's in every file inside /etc/apt/sources.list.d/.

0

Replace the version name with the new Ubuntu version name (e.g trusty to xenial) in /etc/apt/sources.list and any others in /etc/apt/sources.list.d/* feel free to use sed.

Then:

  • apt-get update
  • apt-get upgrade
  • apt-get dist-upgrade

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.