0

The following packages have unmet dependencies:

 codelite : Depends: libclang1-3.4 (>= 3.2) but it is not installable
            Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.0) but it is not installable
            Depends: libgstreamer0.10-0 (>= 0.10.0) but it is not installable
            Depends: libhunspell-1.3-0 but it is not installable
            Depends: liblldb-3.6 but it is not installable
            Depends: libssh-4 (>= 0.6.1) but it is not installable
            Depends: xterm but it is not installable
            Depends: libclang1 but it is not installable
            Depends: clang-format-3.4 but it is not installable or
                     clang-format-3.5 but it is not installable
            Recommends: gdb but it is not installable
            Recommends: lldb (>= 3.4) but it is not installable
            Recommends: nodejs but it is not installable

E: Unable to correct problems, you have held broken packages.

  • Have you tried to fix the broken packages? How and with what result? – user8779 Apr 26 '18 at 11:50
  • I don't know how to fix it. – Yelsin Sadiq Olafemi Apr 26 '18 at 15:13
  • On ubuntu all needed files downloaded and install automatically, but i think deepin is a pain in the ass. – Yelsin Sadiq Olafemi Apr 26 '18 at 15:15
  • I tried install GCC with build essential am getting this error: E: Package 'build-essential' has no installation candidate – Yelsin Sadiq Olafemi Apr 26 '18 at 15:36
  • Try, AS ROOT: apt -get install -f What happens? – user8779 Apr 26 '18 at 17:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.