1

I have moved my hard discs (with a working debian stable system on it) from a computer which had hardware problems to a new, similar one. I would like to have the old system running on the new computer, but I'm having problems with software raid.

It seems that GRUB recognizes everything, but after a few seconds after the star of the booting sequence, I have the following error:

mdadm: no devices listed in conf file were found

But if I boot the system with a knoppix live CD, I can correctly reassemble the raid array and I can access all the files on it.

Which conf file is wrong? What could I do to fix the problem?

This is my /etc/mdadm/mdadm.conf file:

CREATE owner=root group=disk mode=0660 auto=yes HOMEHOST <system> MAILADDR root ARRAY /dev/md/0 metadata=1.2 UUID=... name=voyager.0

The UUID array is the same as the UUID reported by blkid when run from the debian rescue system.

Command grub-install given from the recovery system exits with no errors.

Some more information: an inspection made at the (initramfs) shell shows that /proc/partitions is empty: disks are not recognized. /dev doesn't contain any files named /dev/sd? nor /dev/md*. But if I boot with the Debian Recovery disk, then the raid array is automatically rebuild and the boot partition (which is on another drive) is recognized.

The command mdadm --examine --scan, given from the Rescue CD, gives the following output:

ARRAY /dev/md/0 metadata=1.2 UUID=9cd0e36b:c6cf5152:8806546f:fda3be1d name=voyager:0

I have tried reinstalling GRUB over /dev/sda, over /dev/sda1, over /dev/sdb and /dev/sdc (the last two disks are members of the raid array, while /dev/sda is the boot drive, which isn't member of the array, but with no success. After update-grub I have the same error: mdadm can't see the drive array. The only difference that I can see between the Rescue system, which works, and my system, which is not able to see the raid device, is the linux kernel: the rescue uses version 4.9.0-6-amd64, my system uses 4.9.0-4-686-pae.

  • 1
    Check /etc/fstab and other configuration files that manage block storage and devices. – Mioriin Apr 25 '18 at 16:32
  • 1
    Add the contents of /etc/mdadm.conf to your question. Have the device names (/dev/sda and so on) changed compared to the old system? – Hauke Laging Apr 25 '18 at 16:49
  • 1
    What disk controllers do you have on the old and new machines? Have you also moved interface cables from the old machine to the new one? If you move the disks back, does everything work again? – ajeh Apr 25 '18 at 18:35
  • 1
    Issue the cat /proc/partitions command at the (initramfs) prompt you're dumped at when the system fails to boot end check whether your disk drives are recognized at all. – Ferenc Wágner Apr 26 '18 at 10:28
  • Let us continue this discussion in chat. – zar Apr 27 '18 at 14:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.