1

I'm trying to set some keyboard shortcuts in KDE. Some key combinations will work, and others won't, without explanation. For instance, I'm trying to set "Switch One Desktop Down" to Meta+N. I can set it fine, but then pressing Meta+N doesn't do anything. If I bind it to some other key combination, like Meta+H, or Alt+(, it works fine.

If I open a terminal and type one of the key combinations I set, working ones don't show anything, but non-working ones print things in the terminal. For instance, since Meta+H works, I'll type Meta+H in a terminal, and nothing happens. But if I type Meta+N, I see the terminal display @sn. Same for Meta+I, another key combination that isn't working. If I type Meta+I in a terminal, it prints @si.

I looked in the config files (kglobalshortcutsrc) and nothing looks out of the ordinary there. I tried searching the file for other instances of Meta+N, in case there is a conflict, but there isn't more than one entry.

I tried running dbus-monitor, to see what it's seeing, and I also tried removing kglobalshortcutsrc and khotkeysrc, setting everything to defaults, and setting everything to "none."

I'm using Arch, with the latest KDE packages. If I'm not mistaken, this is a recent development, since KDE didn't have this problem a few days ago. I tried downgrading kwin, but that didn't work.

I also use a Colemak keyboard layout. It seems the non-working keys are ones that aren't the same between QWERTY and Colemak. (Meta+H is in the same spot in both layouts, and it works. Meta+N is in a different place from QWERTY, and it doesn't work.)

0

I Know this is a really old question and I hope you already found a solution, but in case you haven't this might be it:

At the keyboard lay outs in system settings I have both Colemak and qwerty. If I move qwerty to the top, the qwerty shortcuts are activated. If I move Colemak to the top those shortcuts are active. So the solution is to move Colemak to the top.

I think it's a bug, so I made a bug report https://bugs.kde.org/show_bug.cgi?id=425357

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.