1

On a RedHat 6.9 server I have a folder named "/Data", permissions are:

drwxrwxr-x   20 root root 4.0K Apr 24  2018 Data

I want to add a user via ACL to have write permission on this folder for current files and any new files created, so I tried this:

setfacl -d -R -m "u:NewUser:rwX," /Data/

However I get permission denied when I try and create or edit a file.

The output of

mount -l | grep Data

shows:

/dev/mapper/VolGroup00-Data_Vol on /Data type ext4 (rw,acl)

Output of:

tune2fs -l /dev/mapper/VolGroup00-Data_Vol | grep options

shows:

Default mount options:    (none)

So I ran:

tune2fs -o acl /dev/mapper/VolGroup00-Data_Vol

Now output of:

tune2fs -l /dev/mapper/VolGroup00-Data_Vol | grep options

is:

Default mount options:    acl

But I still can't get the ACl to work.

Is there anything I have missed or any other steps I can try to make this work?

  • Just try setfacl -d -R -m u:NewUser:rwx /Data – Raman Sailopal Apr 25 '18 at 10:23
  • have you umount/mount after tune2fs ? – Archemar Apr 25 '18 at 11:14
  • Yes, tried to remount but same problem, command I used was "mount -o remount -o acl /dev/mapper/VolGroup00-Data_Vol /Data" – user3712142 Apr 26 '18 at 10:49
  • Also tried to use "setfacl -d -R -m u:NewUser:rwx /Data" but still get permission denied – user3712142 Apr 26 '18 at 10:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.