1

I have bought two WD Gold 4TB and installed debian sid with kde on a single RAID1 partition, md0:

# cat /proc/mdstat 
Personalities : [raid1] [linear] [multipath] [raid0] [raid6] [raid5] 
[raid4] [raid10] 
md0 : active raid1 sda1[0] sdb1[1]
      3906885632 blocks super 1.2 [2/2] [UU]
      bitmap: 5/30 pages [20KB], 65536KB chunk

unused devices: <none>

# mount | grep md0
/dev/md0 on / type ext4 (rw,noatime,nodiratime,errors=remount-ro,data=ordered)

Now the problem is that hddtemp reported temperature is very high (confirmed by touching the disks), even when idle

# hddtemp /dev/sda /dev/sdb
/dev/sda: WDC WD4002FYYZ-01B7CB1: 59 C
/dev/sdb: WDC WD4002FYYZ-01B7CB1: 57 C

That is more than 30 degrees above room temperature! I have tried to open the lateral panel of the case so to permit further cooling, but it does not help.

I can hear the disks access about every second, with small reads/writes, which I guess prevent spinning down. Also iotop reports few kB/s writings every one/two seconds. In principle such writings should be buffered, but it seems they are instantaneously written.

Thus I have tried both increasing the buffer size:

# echo cfq > /sys/block/sda/queue/scheduler
# echo 10000 > /sys/block/sda/queue/iosched/fifo_expire_async
# echo 250 > /sys/block/sda/queue/iosched/fifo_expire_sync
# echo 80 > /sys/block/sda/queue/iosched/slice_async
# echo 1 > /sys/block/sda/queue/iosched/low_latency
# echo 6 > /sys/block/sda/queue/iosched/quantum
# echo 5 > /sys/block/sda/queue/iosched/slice_async_rq
# echo 3 > /sys/block/sda/queue/iosched/slice_idle
# echo 100 > /sys/block/sda/queue/iosched/slice_sync

(the same for sdb), and also changing the hdparm Power Management flag (see https://ubuntuforums.org/showthread.php?t=795327 ):

# hdparm -B /dev/sda
/dev/sda:
APM_level      = 255
# hdparm -B 64 /dev/sda
/dev/sda:
 setting Advanced Power Management level to 0x40 (64)
 APM_level      = 64

I also note that the Load_Cycle_Count counter increases of about 5/min:

# date; sudo smartctl -a /dev/sda | grep 'Load_Cycle_Count'
Tue Apr 24 16:14:00 CEST 2018
193 Load_Cycle_Count        0x0012   100   100   000    Old_age   Always  -  338
# date; sudo smartctl -a /dev/sda | grep 'Load_Cycle_Count'
Tue Apr 24 16:15:03 CEST 2018
193 Load_Cycle_Count        0x0012   100   100   000    Old_age   Always  -  343

With such rate the disk would break in less than 1 Year (600000 cycles declared).

This is the information from hdparm:

# hdparm -i /dev/sda

/dev/sda:

 Model=WDC WD4002FYYZ-01B7CB1, FwRev=01.01M03, SerialNo=K3H05BLL
 Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=56
 BuffType=DualPortCache, BuffSize=unknown, MaxMultSect=16, MultSect=off
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=7814037168
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4 
 DMA modes:  mdma0 mdma1 mdma2 
 UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6 
 AdvancedPM=yes: disabled (255) WriteCache=enabled
 Drive conforms to: unknown:  ATA/ATAPI-2,3,4,5,6,7

 * signifies the current active mode

The BuffSize=unknown is what makes me suspect a buffer problem. What can I do to know why HDD have such high temperature?

  • You won't have much write cache on a raid 1 (without using a card with a battery backed up cache), any parameter you set on sda/sdb is just discarded in favor of your md device using it. Check your params on md0, but I doubt you'll get anything. – Tensibai Apr 24 '18 at 14:36
  • Hello, in fact hdparm cannot be used with md0. How to change the raid1 buffer? – cipper Apr 24 '18 at 14:43
  • I highly doubt you can, that's a logical raid and as such it can't ensure the buffer won't be lost in case of power failure, so there's no write buffer to avoid corrupting the array. – Tensibai Apr 24 '18 at 14:48
  • Related question (for WD green) on superuser.com: superuser.com/questions/735209/… – Mark Plotnick Apr 24 '18 at 14:59
  • come on, it can't be that sotfware raid1 burns the disks by default – cipper Apr 24 '18 at 15:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.