0

I am trying to test a newer version of a software package and get this error message when trying to launch

Error: unsupported version of GNU C Library (glibc)
       minimum supported version : 2.12
       installed version:        : 2.11

In scenarios such as this

  • does this mean in practical terms that I need to upgrade the OS? I am running SLES 11.4 having glibc 2.11; and SLES 12.3 is the latest currently available,

  • Is there a safe way to update glibc for a given enterprise type of OS such as SLES, or RHEL? Or is that asking for major problems, and is updating glibc something that should not be done manually on a production type of server running expensive licensed software packages?

  • 1
    »»Is there a safe way to update glibc«« : Usually not. But you can install a hidden glibc ( like /opt/glibc212/lib/ ) and point to 2.12 when you run the application. – Knud Larsen Apr 23 '18 at 18:19
  • tried to use glibc-2.12.2, built from source .tar.gz using --prefix=/usr/local/glibc-2.12.2 then doing setenv LD_LIBRARY_PATH /usr/local/glibc-2.12.2/lib:${LD_LIBRARY_PATH} before running software... instead of the clean Error message that is printed which is after a GUI popup I now get segmentation fault (core dumped) immediately at the prompt with no GUI popup. giving up. – ron Apr 25 '18 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.