0

I am trying to run VMware on kali linux but when I try to run it show message that Before you can run VMware several modules must be compiled and loaded into the running kernel

Here is log:

2018-04-23T20:11:48.254+04:30| vthread-1| I125: Log for VMware Workstation pid=8508 version=14.1.0 build=build-7370693 option=Release
2018-04-23T20:11:48.254+04:30| vthread-1| I125: The process is 64-bit.
2018-04-23T20:11:48.254+04:30| vthread-1| I125: Host codepage=UTF-8 encoding=UTF-8
2018-04-23T20:11:48.254+04:30| vthread-1| I125: Host is Linux 4.15.0-2-amd64 Kali GNU/Linux Rolling
2018-04-23T20:11:48.254+04:30| vthread-1| I125: DictionaryLoad: Cannot open file "/usr/lib/vmware/settings": No such file or directory.
2018-04-23T20:11:48.254+04:30| vthread-1| I125: [msg.dictionary.load.openFailed] Cannot open file "/usr/lib/vmware/settings": No such file or directory.
2018-04-23T20:11:48.254+04:30| vthread-1| I125: PREF Optional preferences file not found at /usr/lib/vmware/settings. Using default values.
2018-04-23T20:11:48.254+04:30| vthread-1| I125: DictionaryLoad: Cannot open file "/home/linux/.vmware/config": No such file or directory.
2018-04-23T20:11:48.254+04:30| vthread-1| I125: [msg.dictionary.load.openFailed] Cannot open file "/home/linux/.vmware/config": No such file or directory.
2018-04-23T20:11:48.254+04:30| vthread-1| I125: PREF Optional preferences file not found at /home/linux/.vmware/config. Using default values.
2018-04-23T20:11:48.254+04:30| vthread-1| I125: DictionaryLoad: Cannot open file "/home/linux/.vmware/preferences": No such file or directory.
2018-04-23T20:11:48.254+04:30| vthread-1| I125: [msg.dictionary.load.openFailed] Cannot open file "/home/linux/.vmware/preferences": No such file or directory.
2018-04-23T20:11:48.254+04:30| vthread-1| I125: PREF Optional preferences file not found at /home/linux/.vmware/preferences. Using default values.
2018-04-23T20:11:48.326+04:30| vthread-1| W115: Logging to /tmp/vmware-root/vmware-8508.log
2018-04-23T20:11:48.340+04:30| vthread-1| I125: Obtaining info using the running kernel.
2018-04-23T20:11:48.340+04:30| vthread-1| I125: Created new pathsHash.
2018-04-23T20:11:48.340+04:30| vthread-1| I125: Setting header path for 4.15.0-2-amd64 to "/lib/modules/4.15.0-2-amd64/build/include".
2018-04-23T20:11:48.340+04:30| vthread-1| I125: Validating path "/lib/modules/4.15.0-2-amd64/build/include" for kernel release "4.15.0-2-amd64".
2018-04-23T20:11:48.340+04:30| vthread-1| I125: Failed to find /lib/modules/4.15.0-2-amd64/build/include/linux/version.h
2018-04-23T20:11:48.340+04:30| vthread-1| I125: /lib/modules/4.15.0-2-amd64/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2018-04-23T20:11:48.340+04:30| vthread-1| I125: using /usr/bin/gcc-7 for preprocess check
2018-04-23T20:11:48.348+04:30| vthread-1| I125: Preprocessed UTS_RELEASE, got value "4.15.0-2-amd64".
2018-04-23T20:11:48.348+04:30| vthread-1| I125: The header path "/lib/modules/4.15.0-2-amd64/build/include" for the kernel "4.15.0-2-amd64" is valid.  Whoohoo!
2018-04-23T20:11:48.571+04:30| vthread-1| I125: found symbol version file /lib/modules/4.15.0-2-amd64/build/Module.symvers
2018-04-23T20:11:48.571+04:30| vthread-1| I125: Reading symbol versions from /lib/modules/4.15.0-2-amd64/build/Module.symvers.
2018-04-23T20:11:48.597+04:30| vthread-1| I125: Read 20056 symbol versions
2018-04-23T20:11:48.597+04:30| vthread-1| I125: Reading in info for the vmmon module.
2018-04-23T20:11:48.597+04:30| vthread-1| I125: Reading in info for the vmnet module.
2018-04-23T20:11:48.597+04:30| vthread-1| I125: Reading in info for the vmblock module.
2018-04-23T20:11:48.597+04:30| vthread-1| I125: Reading in info for the vmci module.
2018-04-23T20:11:48.597+04:30| vthread-1| I125: Reading in info for the vsock module.
2018-04-23T20:11:48.597+04:30| vthread-1| I125: Setting vsock to depend on vmci.
2018-04-23T20:11:48.597+04:30| vthread-1| I125: Invoking modinfo on "vmmon".
2018-04-23T20:11:48.600+04:30| vthread-1| I125: "/sbin/modinfo" exited with status 256.
2018-04-23T20:11:48.600+04:30| vthread-1| I125: Invoking modinfo on "vmnet".
2018-04-23T20:11:48.602+04:30| vthread-1| I125: "/sbin/modinfo" exited with status 256.
2018-04-23T20:11:48.602+04:30| vthread-1| I125: Invoking modinfo on "vmblock".
2018-04-23T20:11:48.604+04:30| vthread-1| I125: "/sbin/modinfo" exited with status 256.
2018-04-23T20:11:48.604+04:30| vthread-1| I125: Invoking modinfo on "vmci".
2018-04-23T20:11:48.606+04:30| vthread-1| I125: "/sbin/modinfo" exited with status 256.
2018-04-23T20:11:48.606+04:30| vthread-1| I125: Invoking modinfo on "vsock".
2018-04-23T20:11:48.608+04:30| vthread-1| I125: "/sbin/modinfo" exited with status 0.
2018-04-23T20:11:48.623+04:30| vthread-1| I125: to be installed: vmmon status: 0
2018-04-23T20:11:48.623+04:30| vthread-1| I125: to be installed: vmnet status: 0
2018-04-23T20:11:48.639+04:30| vthread-1| I125: Obtaining info using the running kernel.
2018-04-23T20:11:48.639+04:30| vthread-1| I125: Setting header path for 4.15.0-2-amd64 to "/lib/modules/4.15.0-2-amd64/build/include".
2018-04-23T20:11:48.639+04:30| vthread-1| I125: Validating path "/lib/modules/4.15.0-2-amd64/build/include" for kernel release "4.15.0-2-amd64".
2018-04-23T20:11:48.639+04:30| vthread-1| I125: Failed to find /lib/modules/4.15.0-2-amd64/build/include/linux/version.h
2018-04-23T20:11:48.639+04:30| vthread-1| I125: /lib/modules/4.15.0-2-amd64/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2018-04-23T20:11:48.639+04:30| vthread-1| I125: using /usr/bin/gcc-7 for preprocess check
2018-04-23T20:11:48.646+04:30| vthread-1| I125: Preprocessed UTS_RELEASE, got value "4.15.0-2-amd64".
2018-04-23T20:11:48.646+04:30| vthread-1| I125: The header path "/lib/modules/4.15.0-2-amd64/build/include" for the kernel "4.15.0-2-amd64" is valid.  Whoohoo!
2018-04-23T20:11:48.867+04:30| vthread-1| I125: found symbol version file /lib/modules/4.15.0-2-amd64/build/Module.symvers
2018-04-23T20:11:48.867+04:30| vthread-1| I125: Reading symbol versions from /lib/modules/4.15.0-2-amd64/build/Module.symvers.
2018-04-23T20:11:48.892+04:30| vthread-1| I125: Read 20056 symbol versions
2018-04-23T20:11:48.893+04:30| vthread-1| I125: Kernel header path retrieved from FileEntry: /lib/modules/4.15.0-2-amd64/build/include
2018-04-23T20:11:48.893+04:30| vthread-1| I125: Update kernel header path to /lib/modules/4.15.0-2-amd64/build/include
2018-04-23T20:11:48.893+04:30| vthread-1| I125: Validating path "/lib/modules/4.15.0-2-amd64/build/include" for kernel release "4.15.0-2-amd64".
2018-04-23T20:11:48.893+04:30| vthread-1| I125: Failed to find /lib/modules/4.15.0-2-amd64/build/include/linux/version.h
2018-04-23T20:11:48.893+04:30| vthread-1| I125: /lib/modules/4.15.0-2-amd64/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2018-04-23T20:11:48.893+04:30| vthread-1| I125: using /usr/bin/gcc-7 for preprocess check
2018-04-23T20:11:48.900+04:30| vthread-1| I125: Preprocessed UTS_RELEASE, got value "4.15.0-2-amd64".
2018-04-23T20:11:48.900+04:30| vthread-1| I125: The header path "/lib/modules/4.15.0-2-amd64/build/include" for the kernel "4.15.0-2-amd64" is valid.  Whoohoo!
2018-04-23T20:11:48.902+04:30| vthread-1| I125: Found compiler at "/usr/bin/gcc"
2018-04-23T20:11:48.906+04:30| vthread-1| I125: Got gcc version "7".
2018-04-23T20:11:48.906+04:30| vthread-1| I125: The GCC version matches the kernel GCC minor version like a glove.
2018-04-23T20:11:48.910+04:30| vthread-1| I125: Got gcc version "7".
2018-04-23T20:11:48.910+04:30| vthread-1| I125: The GCC version matches the kernel GCC minor version like a glove.
2018-04-23T20:11:48.912+04:30| vthread-1| I125: Trying to find a suitable PBM set for kernel "4.15.0-2-amd64".
2018-04-23T20:11:48.912+04:30| vthread-1| I125: No matching PBM set was found for kernel "4.15.0-2-amd64".
2018-04-23T20:11:48.912+04:30| vthread-1| I125: The GCC version matches the kernel GCC minor version like a glove.
2018-04-23T20:11:48.912+04:30| vthread-1| I125: Validating path "/lib/modules/4.15.0-2-amd64/build/include" for kernel release "4.15.0-2-amd64".
2018-04-23T20:11:48.912+04:30| vthread-1| I125: Failed to find /lib/modules/4.15.0-2-amd64/build/include/linux/version.h
2018-04-23T20:11:48.912+04:30| vthread-1| I125: /lib/modules/4.15.0-2-amd64/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2018-04-23T20:11:48.912+04:30| vthread-1| I125: using /usr/bin/gcc-7 for preprocess check
2018-04-23T20:11:48.922+04:30| vthread-1| I125: Preprocessed UTS_RELEASE, got value "4.15.0-2-amd64".
2018-04-23T20:11:48.922+04:30| vthread-1| I125: The header path "/lib/modules/4.15.0-2-amd64/build/include" for the kernel "4.15.0-2-amd64" is valid.  Whoohoo!
2018-04-23T20:11:48.925+04:30| vthread-1| I125: The GCC version matches the kernel GCC minor version like a glove.
2018-04-23T20:11:48.925+04:30| vthread-1| I125: Validating path "/lib/modules/4.15.0-2-amd64/build/include" for kernel release "4.15.0-2-amd64".
2018-04-23T20:11:48.925+04:30| vthread-1| I125: Failed to find /lib/modules/4.15.0-2-amd64/build/include/linux/version.h
2018-04-23T20:11:48.925+04:30| vthread-1| I125: /lib/modules/4.15.0-2-amd64/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2018-04-23T20:11:48.925+04:30| vthread-1| I125: using /usr/bin/gcc-7 for preprocess check
2018-04-23T20:11:48.937+04:30| vthread-1| I125: Preprocessed UTS_RELEASE, got value "4.15.0-2-amd64".
2018-04-23T20:11:48.937+04:30| vthread-1| I125: The header path "/lib/modules/4.15.0-2-amd64/build/include" for the kernel "4.15.0-2-amd64" is valid.  Whoohoo!
2018-04-23T20:11:48.937+04:30| vthread-1| I125: Using temp dir "/tmp".
2018-04-23T20:11:48.940+04:30| vthread-1| I125: Obtaining info using the running kernel.
2018-04-23T20:11:48.940+04:30| vthread-1| I125: Setting header path for 4.15.0-2-amd64 to "/lib/modules/4.15.0-2-amd64/build/include".
2018-04-23T20:11:48.940+04:30| vthread-1| I125: Validating path "/lib/modules/4.15.0-2-amd64/build/include" for kernel release "4.15.0-2-amd64".
2018-04-23T20:11:48.940+04:30| vthread-1| I125: Failed to find /lib/modules/4.15.0-2-amd64/build/include/linux/version.h
2018-04-23T20:11:48.940+04:30| vthread-1| I125: /lib/modules/4.15.0-2-amd64/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2018-04-23T20:11:48.940+04:30| vthread-1| I125: using /usr/bin/gcc-7 for preprocess check
2018-04-23T20:11:48.951+04:30| vthread-1| I125: Preprocessed UTS_RELEASE, got value "4.15.0-2-amd64".
2018-04-23T20:11:48.951+04:30| vthread-1| I125: The header path "/lib/modules/4.15.0-2-amd64/build/include" for the kernel "4.15.0-2-amd64" is valid.  Whoohoo!
2018-04-23T20:11:49.171+04:30| vthread-1| I125: found symbol version file /lib/modules/4.15.0-2-amd64/build/Module.symvers
2018-04-23T20:11:49.171+04:30| vthread-1| I125: Reading symbol versions from /lib/modules/4.15.0-2-amd64/build/Module.symvers.
2018-04-23T20:11:49.196+04:30| vthread-1| I125: Read 20056 symbol versions
2018-04-23T20:11:49.196+04:30| vthread-1| I125: Invoking modinfo on "vmmon".
2018-04-23T20:11:49.200+04:30| vthread-1| I125: "/sbin/modinfo" exited with status 256.
2018-04-23T20:11:49.200+04:30| vthread-1| I125: Invoking modinfo on "vmnet".
2018-04-23T20:11:49.203+04:30| vthread-1| I125: "/sbin/modinfo" exited with status 256.
2018-04-23T20:11:49.594+04:30| vthread-1| I125: Setting destination path for vmmon to "/lib/modules/4.15.0-2-amd64/misc/vmmon.ko".
2018-04-23T20:11:49.595+04:30| vthread-1| I125: Extracting the vmmon source from "/usr/lib/vmware/modules/source/vmmon.tar".
2018-04-23T20:11:49.606+04:30| vthread-1| I125: Successfully extracted the vmmon source.
2018-04-23T20:11:49.606+04:30| vthread-1| I125: Building module with command "/usr/bin/make -j4 -C /tmp/modconfig-stxrjw/vmmon-only auto-build HEADER_DIR=/lib/modules/4.15.0-2-amd64/build/include CC=/usr/bin/gcc IS_GCC_3=no"
2018-04-23T20:11:52.158+04:30| vthread-1| W115: Failed to build vmmon.  Failed to execute the build command.
2018-04-23T20:11:52.161+04:30| vthread-1| I125: Setting destination path for vmnet to "/lib/modules/4.15.0-2-amd64/misc/vmnet.ko".
2018-04-23T20:11:52.161+04:30| vthread-1| I125: Extracting the vmnet source from "/usr/lib/vmware/modules/source/vmnet.tar".
2018-04-23T20:11:52.170+04:30| vthread-1| I125: Successfully extracted the vmnet source.
2018-04-23T20:11:52.170+04:30| vthread-1| I125: Building module with command "/usr/bin/make -j4 -C /tmp/modconfig-stxrjw/vmnet-only auto-build HEADER_DIR=/lib/modules/4.15.0-2-amd64/build/include CC=/usr/bin/gcc IS_GCC_3=no"
2018-04-23T20:11:56.805+04:30| vthread-1| I125: Successfully built vmnet.  Module is currently at "/tmp/modconfig-stxrjw/vmnet.o".
2018-04-23T20:11:56.805+04:30| vthread-1| I125: Found the vmnet symvers file at "/tmp/modconfig-stxrjw/vmnet-only/Module.symvers".
2018-04-23T20:11:56.805+04:30| vthread-1| I125: Installing vmnet from /tmp/modconfig-stxrjw/vmnet.o to /lib/modules/4.15.0-2-amd64/misc/vmnet.ko.
2018-04-23T20:11:56.809+04:30| vthread-1| I125: Registering file "/lib/modules/4.15.0-2-amd64/misc/vmnet.ko".
2018-04-23T20:11:57.108+04:30| vthread-1| I125: "/usr/lib/vmware-installer/2.1.0/vmware-installer" exited with status 0.
2018-04-23T20:11:57.109+04:30| vthread-1| I125: Registering file "/usr/lib/vmware/symvers/vmnet-4.15.0-2-amd64".
2018-04-23T20:11:57.404+04:30| vthread-1| I125: "/usr/lib/vmware-installer/2.1.0/vmware-installer" exited with status 0.

I tried to google but was unable to find relevant post.

3

Issue At Hand

You are reporting that you are unable to run VMware on Kali Linux. According to the errors you have posted your Operating System is missing the VMware modules necessary to run.

I will take this time to point out that Kali Linux is not meant as a general purpose Operating System. You may continue to run into these kinds of errors using software not designed for Kali Linux. Running virtualization or hypervisor software is not an intended function of Kali Linux. One possible solution to your issue would be to run your virtualization software on Ubuntu, Debian, or any other general purpose operating system instead.

If you wish to continue using Kali Linux or encounter the same error in a different Operating System the following steps may work as a possible solution to the above error.

Possible Solutions

I will be referencing this post as it contains a few different possible fixes.

First off try and run this command:

sudo vmware-modconfig --console --install-all

This should install all VMware modules. You should now be able to run Vmware as expected. Look over this VMware forum post as they cover additional scripts you may need to run to verify the install process.

Alternatively, you could try this first:

sudo apt-get install build-essential linux-headers-$(uname -r) open-vm-dkms
sudo ln -s /usr/src/linux-headers-$(uname -r)/include/generated/uapi/linux/version.h /usr/src/linux-headers-$(uname -r)/include/linux/version.h 

After which run: sudo vmware-config-tools.pl. It might be necessary to run sudo vmware-modconfig --console --install-all again after this is complete.

Starting from Scratch

You may need to start over with a fresh install of VMware. Purge the existing installation by running sudo vmware-installer -u vmware-player. Then rerun the installer script, i.e: ./VMware-*.bundle.

I would also verify that your graphics drivers and all other parts of your system are fully up to date.

Conclusion

Again, I suggest you use a different Operating System than Kali Linux to complete this task. Please read over this post in its entirety before going with a possible fix. Remember you need to install the proper kernel headers for your kernel to get this to work. I am also including a link to a guide on installing VMware on Kali Linux. There are even some comments in that post on how to troubleshoot the issue further.

I am also including a link to the Official Kali Linux documentation on how to install VMware tools as well as a link to another stack exchange post that appears to be related to this issue.

Please comment if there are any questions about this answer. I appreciate corrections to any misconceptions and feedback on how to improve my posts. Best of Luck!

  • sudo apt-get install build-essential linux-headers-$(uname -r) open-vm-dkms Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package open-vm-dkms – Raakh Apr 23 '18 at 20:55
  • sudo apt-get install open-vm-tools-dkms Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package open-vm-tools-dkms – Raakh Apr 23 '18 at 20:57
  • @Raakh, what is the output of uname -a and cat \etc\issue? Also does your sources.list match what the official Kali Linux Documentation says exactly? No more no less. Here is some advice from the Kali Linux site on how to set up VMware tools. This post could help you too. – kemotep Apr 24 '18 at 1:55
  • The actual problem ended with new and fresh installation from its official website. I really appreciate the nice explanation and thanks to all who helped me – Raakh Apr 24 '18 at 7:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.