0

I am on a redhat box Linux version 2.6.32-696.20.1.el6.x86_64 (mockbuild@x86-042.build.eng.bos.redhat.com) (gcc version 4.4.7 20120313 (Red Hat 4.4.7-18) (GCC) ) #1 SMP Fri Jan 12 15:07:59 EST 2018 (only user rights)

and need to install glic_2.14 as I am getting the following error from different library '/lib64/libc.so.6: version GLIBC_2.14' not found (required by /home/user/q//l64/./p.so)

After downloading the tarball from here, I followed the steps described in this answer to install. But when I look into the glibc directory after make install I don't see a /lib folder just

  • /tmp/glibc-2.14/libio and

  • /tmp/glibc-2.14/libidn

and they don't contain archive libraries (.so) but just .c files.

Unsurprisingly, when I add them to LD_LIBRARY_PATH the error above doesn't go away.

Thanks for the help

closed as off-topic by Jeff Schaller, G-Man, Romeo Ninov, telcoM, andcoz Apr 30 '18 at 13:15

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, G-Man, Romeo Ninov, telcoM, andcoz
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Please update your question to show exactly the commands you used. I can see examples are in the referenced question but it's all too easy to miss out a step accidentally, so please show us what you've tried. (For example, you're referencing /tmp/glibc-2.14 but the referenced question doesn't mention that anywhere.) – roaima Apr 30 '18 at 11:38
0

Sorry it turned out that adding the build directory tmp/glibc-2.14/build/ (which contains libc.so.6) to $LD_LIBRARY_PATH solved the problem.

Not the answer you're looking for? Browse other questions tagged or ask your own question.