1

On Oracle Linux Server (similar to Centos/RHEL 6) I am trying to run the ICIJ Offshore Leaks neo4j AppImage (download link). The image has the name neo4j-desktop-for-icij-1.0.0-x86_64.AppImage.

After making the file executable and issuing

./neo4j-desktop-for-icij-1.0.0-x86_64.AppImage

I get the following error:

fuse: failed to exec fusermount: Permission denied

Cannot mount AppImage, please check your FUSE setup.
You might still be able to extract the contents of this AppImage 
if you run it with the --appimage-extract option. 
See https://github.com/AppImage/AppImageKit/wiki/FUSE 
for more information
open dir error: No such file or directory

Does the AppImage need an external FUSE package? I then ran as suggested

./neo4j-desktop-for-icij-1.0.0-x86_64.AppImage --appimage-extract

and this indeed extracted the content (to a sub directory squashfs-root). But how do I start the app now? I tried

./squashfs-root/AppRun

but this gives me

Desktop file is missing. Please run ./squashfs-root/AppRun from within an AppImage.

So how do I run/start the app? Thanks for any pointers!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.