0

so I cloned a folder into another disk (freshly formatted as ext4) and it completed successfully.

rsync -aiv --delete source-folder destination-folder

My issue is that if I ran the command above but with --dry-run as an additional parameter, I expect that --no-- files/folders will show up. But all the files and folders shows up again.

Any ideas what I could be doing wrong?

I'm running rsync 3.1.1 and Ubuntu 16.04.

Thanks!

ps. this is not a desktop machine as such there's no "X"

1

I believe this is to do with the flags/params you are using. -aiv try with -avz instead.

The ‘i’ parameter is for finer grained control over the information you see, usually you would set a level of info indicated by a number. It’s likely you’re not making any changes or would be should it have been a real run so it’s just listing off it looping over all the files.

Run the avz flags instead in dry mode and that should confirm :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.