Without me doing anything, firefox changed the fonts (the degree of change is differenet for different sites) to something else (please see image) and I am unable to change it back.

This is a clean profile that has no addons.

messed up firefox fonts

I have ensured that the settings are at its default

settings are at default

And this problem does not affect TorBrowser which is based on firefox and Chromium.

torbrowser no font problem

I am on Debian 10 (Buster, testing), firefox 59, KDE.

Solutions I tried:

  • I have checked the KDE settings for font.
  • I have almost all possible fonts installed (6GB).
  • Deleted everything in the .cache folder and ran fc-cache -rv.
  • Installed a fresh firefox-esr (v52) with new profile and no addons, and it has the same problem.

Why is this happening, and how do I solve it.

Thank you so much for reading this.

  • disable uBlock, try again, verify, change settings accordingly
    – A.B
    Commented Apr 22, 2018 at 8:11
  • @A.B, thank you. I have tried with no addons at all. It did not help. Is there something else that I can do?
    – music
    Commented Apr 25, 2018 at 5:36

1 Answer 1


Renamed the /home/user/.fonts folder to .fonts-disabled. Ran fc-cache -rv Now those fonts will not be used by the system.

Problem solved - firefox now has correct fonts.

That folder had fonts that I have been collecting for 15yrs (6gb), and something there was corrupting firefox. And after getting rid of it, I realized that I don't need many fonts (just the basic ones from debian plus mscorefonts was more than enough). Even other language fonts (like japanese) are still working.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .