1

I wanted to secure erase my old Kingston SH100S3/120G SSD. I tried to follow the article here.

I checked the SSD with hdparm -I /dev/sda command. Since it showed "frozen" security state even after multiple boots, I decided to put the SSD into an external USB case and connected it to Laptop running Ubuntu 17.10. I had no problem with the frozen state anymore, but it displayed "not supported: enhanced erase".

I thought I try the command hdparm --user-master u --security-set-pass Eins /dev/sdb anyway. It complained about something like the feature is not supported - unfortunately, I don't have the exact output anymore.

I left for a half an hour during which the SSD stayed in the case connected to the PC. When I came back it was quite hot. I disconnected it and installed back to the original PC.

Afterwards I tried to use the SSD in the original PC (SATA Interface), and also in a docking bay, and finally in the USB case, it did not show in either case any sings of life. In the PC it beeped twice during the BIOS test and the Disk did not get detected anymore. In the USB case it did not show up anymore either. Dmesg shows messages like this: Buffer I/O error on dev dm-1, logical block 0, async page read

I can't bring it back to life. Did the hdparm command or the external USB case brick the SSD? The external USB case with HDD works flawlessly.

  • You could try your luck with a psid revert if the SSD supports it github.com/Drive-Trust-Alliance/sedutil/wiki/PSID-Revert — of course that still requires the drive to be detected at all, otherwise it may just be a goner – frostschutz Apr 21 '18 at 22:27
  • It might be trying to write zeros to every sector on the disk. Try leaving it powered up for a few hours to let it finish. If you know the normal write speed you could calculate how long it should take. – meuh Apr 22 '18 at 18:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.