0

Background

Two weeks ago, I was on the kernel 4.13.0-36, and a routine update installed 4.13.0-37 and 4.13.0-38 automatically. After that, I was unsuccessful in getting my laptop to boot beyond the login screen (link to bug). I fixed (temporarily solved) it by removing -37, -38, and apt-mark holding -36. I continued to boot in -36 without any issues for about two weeks now.

Problem

I used my laptop as usual last night and then eventually shut it down. I believe I ran some routine updates through apt. Today morning I was unable to boot past the login screen.

Situation: My grub pops up by default. Then I choose the top option, which is -36. It runs through the boot process, asking me to unlock cryptswap. I do that. It finishes up, shows the login screen. Irrespective of whether or not I interact with it (e.g., moving the cursor around, typing my password really quick, or even booting into tty2 or any other tty), it freezes in the next 6 seconds or so.

My current suspicion is that the problem must be caused by some recent package that was updated, or something to do with the kernels. Whatever it is, is crashing at login while trying to launch GUI. If I understand correctly, it is likely to be some process that occurs at startup.

Things I have tried without much luck

  • nomodeset option: no luck
  • -36 recovery boot, and then trying to dpkg repair packages
  • chroot (through a live USB session) followed by apt upgrade (according to this post)
  • reinstalling -37, -38 because apparently "a fix was committed" at the same link to the bug above. (tried nomodeset with all these kernels, too, didn't work)
  • switching to another tty: doesn't work because machine freezes irrespective of what you do within 5-6 seconds

Logs and info

I'm just trying to provide down here anything I think is relevant. If you believe something else might help, please let me know and I'll be happy to upload it.

  • DMESG output through chroot session (link)
  • Auth log for one such failed boot (link)
  • dpkg log from the last successful graphical session (yesterday) (1. all: link; 2. only recently installed, filtered using grep "install": link)
  • syslog from one such failed boot (link)
  • Basic information about hardware using lspci (link)
0

This bug was fixed in the package linux - 4.13.0-39.44:

https://bugs.launchpad.net/ubuntu/+source/intel-microcode/+bug/1759920/comments/113

We worked around it until now by disabling the sssd apparmor profile

ln -s /etc/apparmor.d/usr.sbin.sssd /etc/apparmor.d/disable/
apparmor_parser -R /etc/apparmor.d/usr.sbin.sssd
  • /etc/apparmor.d/usr.sbin.sssd : No such file or directory – Happy Torturer Apr 23 '18 at 12:53
  • @HappyTorturer: sssd is probably not installed on your system – Btg Apr 24 '18 at 19:57
  • I ended up with reinstalling Linux and blocking updates for linux-images, headers, etc and xserver – Happy Torturer Apr 25 '18 at 5:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.