1

This is my first time attempting to install debian and I am getting an error. I was hoping someone could help me with it. The following is how I went about downloading & installing:

I first downloaded the image file from: here (dvd, amd64 - because my processor is an: i7-4790K )

I then burned the .iso file to a cd using

this tool (with the slowest option: 4x).

Finally I went in to my bios and and changed the boot priority to boot from cd / dvd first.

When I rebooted my pc I was prompted with the install wizard

But if I select either Graphical install or Install I get the following:

First: enter image description here

And then the error: enter image description here

UPDATE Thanks for the helpful comments. I checked my bios version and sure enough it was quite outdated compared to the newer available versions.

(my motherboard is the: Z97 Gaming 9 ACK - and my bios version is Click BIOS 4 V1.10 ) 

Unfortunately I cannot update it yet as it requires a USB which I actually don't have right now.

In the meantime I tried burning Mint to the cd and booted that, but the exact same error appears.

Also, I tried turning off acpi by adding acpi=off & pci=noacpi but unfortunately it still gives me the error.

UPDATE 2 So i finally managed to get my hands on a USB stick.

I successfully updated my bios but unfortunately i'm still getting the SATA device failing IDENTIFY PACKET error.

Furthermore since i now had a USB i tried disconnecting my cd / dvd drive (which was the device connected to the 8th SATA port) and boot from the USB instead. To my surprise this actually worked...with a "small" problem unfortunatly.

Basically after booting from the USB everything is suuuper slow and laggy.

The mouse is actually pretty responsive and changes its icon and such just fine, but every time i try to interact with the Desktop environment it is insanely slow (pressing keys or opening folderes, or even just hovering over stuff takes several seconds to register). This could be unrelated but i would appreciate it if someone knows how to fix it.

  • I would search for BIOS firmware update – Fabian Apr 20 '18 at 19:59
  • Thanks, I will try that and update the question if it works :) – Stavsen Apr 20 '18 at 20:00
  • Very hard to suggest anything w/o details of your hardware configuration. It may or may not be the same as askubuntu.com/questions/228927/… so I suggest you do some more google-fu. – ajeh Apr 20 '18 at 20:18
  • Linux failed to parse ACPI table. Try to udate firmware and if it failed -- disable ACPI : askubuntu.com/questions/160036/… – user996142 Apr 20 '18 at 22:28
  • I turned off ACPI but unfortunately it still gives me the same error (even on Mint) :( – Stavsen Apr 21 '18 at 17:25
1

That ACPI error might be harmless and/or avoidable with a kernel parameter libata.noacpi=1. See this blog: http://blog.le-vert.net/?p=24

The fact that your ata8.00 or in other words, your 8th SATA device, is failing an IDENTIFY PACKET DEVICE request might be more serious. Do you have an old IDE/SATA device in your system that might be failing? If so, consider disconnecting it to see if it helps.

Also, since your system is booting with the default quiet option, there are no boot messages identifying what operations are successful before the system encounters a failure that causes it to get stuck.

You might want to press E in the install media's boot menu. It should allow you to edit the boot options of the installer: add verbose to the end of the line as a separate word. Then press whatever key is indicated on screen to boot with the customized options. There should now be a lot more messages.

If the system hangs so hard it cannot even output an error message of the actual thing that causes problems, then knowing what was the last successful operation just before the hang is helpful: armed with that information, people who know the internal workings of the installer can then hopefully identify the problem.

  • Thanks for the answer! My dvd drive (with the disk im trying to boot from) is the device connected to the 8th sata port...so im not sure if i can disconnect it . I will try the verbose option now, updates to follow. :) – Stavsen Apr 22 '18 at 0:35
  • So i tried removing the quite/splash option and adding verbose but it didn't do much :( it prints the exact same error – Stavsen Apr 22 '18 at 0:59
  • @Stavsen I'd suggest to update the outdated firmware and then try again the above mentioned kernel parameter, looks promising – Fabian Apr 30 '18 at 4:35
  • I updated my firmware but unfortunately im still getting the same error. Even when i try to boot from USB it gives me the error. Oddly enough though, it does work if i disconnect my cd / dvd drive and boot from USB. I'm just a noob but could it have anything to do with maybe my cd / dvd drive having a bad driver that isn't responding to these requests properly or something? – Stavsen May 5 '18 at 14:47
  • A CD/DVD drive has a pretty standard command set. The fact that it's not responding to an IDENTIFY PACKET DEVICE request would most likely mean the drive is somehow faulty. – telcoM May 5 '18 at 15:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.