0

I've been trying to do the steps from 18.4 from here: https://debian-live.alioth.debian.org/live-manual/stable/manual/html/live-manual.en.html#847

When running the lb build I get an error at the lb bootstrap_archive-keys step.

My setup is a Windows 10 host running a Debian Jessie 8.4 VMWare guest. I've tried both NAT and Bridged network setup, but in both cases I get the same error. The machine is connected to the company network which requires proxy authentication.

The machine is connected to the company network which requires proxy authentication. Before running the lb build I've set from command line the http_proxy, https_proxy and ftp_proxy variables like this:

> export http_proxy=http://myuser:mypassword@192.168.1.1:3128
> export https_proxy=http://myuser:mypassword@192.168.1.1:3128
> export ftp_proxy=http://myuser:mypassword@192.168.1.1:3128

In the auto/config file for live-build I've specified the --apt-http-proxy and the --apt-ftp-proxy parameters so the config file looks like this:

#!/bin/sh

lb config noauto \
     --architectures i386 \
     --linux-flavours 686-pae \
     --apt-http-proxy http://myuser:mypassword@192.168.1.1:3128 \
     --apt-ftp-proxy http://myuser:mypassword@192.168.1.1:3128 \
     "${@}"

The error I get at the lb bootstrap_archive_keys step is:

[2018-04-19 16:43:27] lb bootstrap_archive-keys 
Get:1 http://ftp.debian.org jessie InRelease [2829 B]
Splitting up /var/lib/apt/lists/partial/ftp.debian.org_debian_dists_jessie_InRelease into data and signature failedIgn http://ftp.debian.org jessie InRelease
E: GPG error: http://ftp.debian.org jessie InRelease: Clearsigned file isn't valid, got 'NODATA' (does the network require authentication?)
P: Begin unmounting filesystems...
P: Saving caches...
Reading package lists...
Building dependency tree...

The previous steps: lb build noauto, lb bootstrap, lb bootstrap_cache restore, lb bootstrap_cdebootstrap, lb bootstrap_debootstrap work fine.

I've searched for the GPG error: http://ftp.debian.org jessie InRelease: Clearsigned file isn't valid, got 'NODATA' (does the network require authentication?) error. Most people have the problem of a transparent proxy (like here: https://askubuntu.com/questions/474549/got-nodata-issue-nodata-does-the-network-require-authentication) which is not the case for me, it's not transparent, it's there I know it :) and also an apt-get update works properly (proxy set in /etc/apt/apt.conf)

There was an older discussion with a very similar issue to mine here: https://lists.debian.org/debian-live/2013/06/msg00078.html but this was quite a while ago, and it was marked as fixed later versions. I'm using the latest version of live-build, 4.0.3-1 and live-tools 4.0.2-1.1

I can confirm that the problem doesn't appear if the system has a direct internet connection.

I would really appreciate if someone could shed some light on this problem, or if someone met similar problems.

Thanks, Gabor

P.S. This used to work in this setup a while back (last summer or something like that). What could have changed since then?

-1

try:

export LB_APT_HTTP_PROXY="...."

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.