1

I have a Dell Latitude 5480 with a dedicated Nvidia graphics card and an integrated Intel graphics chip. Trying to debug some issues with CPU fan, I tried to change the graphics card used by the system using the GUI tool: enter image description here

After I changed it, the system asked me for a reboot. After that, I am not able to boot the system again. I get the usual splash screen asking me to unlock the encrypted disk and after that just a black screen.

I tried to change various boot settings in grub using this tutorial, but the results are always the same. If I use nomodeset, I cannot even get past the drive decryption step since the input is just written to the top left hand of the screen and not in the input field.

I was able to get some limited abilitied from the recovery mode, but after a minute or so working in the root mode, the recovery menu appears again and the inputs get totally messed up until I reboot.

How can I undo the graphics card switch from the command line?

2

After several hours of no luck, a colleague of mine came in and found two articles(How To Switch Between Intel and Nvidia Graphics Card on Ubuntu, How to select integrad graphic card over NVIDIA?) which helped a lot. In my case, I first wanted to get out of the weird console which screwed itself up after some time.

It turned out that the Intel graphics adapter worked, just not when I was starting the system normally. So I got to the broken terminal and before it had a chance to go haywire, I did the following:

mount -o rw,remount /

This remounted the filesystem as read/write, so that I can persist the changes I make.

startx

Incredibly, this started X in root mode with the Intel graphics adapter. I thought I would be able to use the same GUI tool to switch the adapters back, but when I tried, I got a Python traceback with an error message saying that it cannot find dbus. Dbus was stopped and I wasn't able to start it. It was impossible to switch to another terminal using Ctrl+Alt+F#, touchpad didn't work (but USB mouse did), Cinnamon immediately crashed and did so even after I tried to restart it. But I had the basic interface up already, so I could open up GNOME Terminal to work with.

The final step was to run the following command from the article mentioned above:

prime-select nvidia

This changed some symlinks and maybe edited a config file or two, and upon the next restart, I am back where I was before I tried changing the GPU used by the system!

Lesson learned: Despite large improvements in the past couple of years, there are still trivial things you can do to the system which will bring it to an unbootable state. Next time, I will not allow the installer to choose its own filesystem and will pick one which supports snapshots, like btrfs. Having a snapshot would prevent issues like this one.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.