0

I tried to mount manually on my Linux shared folders from windows server 2012 R2.

The syntaxe is right but Im stuck on the same issue error 13:

#mount.cifs //ip/division /mnt/division -o username=bob@dude-uk,password=myscretpass,vers=2.1
dmesg:
Status code returned 0xc000006d STATUS_LOGON_FAILURE
CIFS VFS: Send error in SessSetup = -13
CIFS VFS: cifs_mount failed w/return code = -13

If I tried other vers= options I got the same issue. If I remove the option vers= then syslog claim :

No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.

If I use option sec= then I specify this option then I got error 126

#mount.cifs //ip/division /mnt/division -o username=bob@dude-uk,password=myscretpass,vers=2.1,sec=krb5
mount error(126): Required key not available

Package Keyutils is installed.

If I tried other sec= options I got error 22 or error 13

if I tried to prompt the password:

#mount.cifs //ip/division /mnt/division -o username=bob@dude-uk
Password for bob@dude-uk@//ip/division:  
mount error(13): Permission denied

Nemo (file explorer in Linux Mint) can mount the shared folders. MacOsx can mount shared folders.

My kernel is 4.13 Mount.cifs is 6.4 I tried to mount manually before setup my fstab.

Do you have any idea ?

0

After read Bugzilla: bugzilla issue Kernel 4.13 got an issue to use mount.cifs command properly. I must boot on 4.12 kernel - I will update my post after that

0

I create another user instead of use account administrator and it works !

0

I had the same error with the mount.cifs. I've used this line time and time again, but wouldn't work for a random reason. mount.cifs //server/domain_share /mnt -o user=admin,sec=ntlmsspi I tried the mount.cifs ///domain_share /mnt -o user=admin,domain=,sec=ntlmsspi and gave the same error. I attempted many variations of IPs and domain shares, and found that if I too away the DNS name and added the IP along with the suggested domain=domain_name.org I was able to get the access. The fix was mount.cifs ///domain_share /mnt -o user=admin,domain=,sec=ntlmsspi

The authentication piece wouldn't allow me to input a Password with the DNS name of the server, had to go bare bones with the address and authentication to allow me access. Now that it's connected I can use the original line of code I've always used... Not sure about why the problem occurred, but there's the fix for my error (13).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.