1

First attempt to build netplan.io on Debian 9 and have the errors below. Can you tell me what I need to install?

Package yaml-0.1 was not found in the pkg-config search path.
Perhaps you should add the directory containing  

`yaml-0.1.pc'   

to the PKG_CONFIG_PATH environment variable
No package 'yaml-0.1' found

Package uuid was not found in the pkg-config search path.
Perhaps you should add the directory containing 

`uuid.pc'

to the PKG_CONFIG_PATH environment variable
No package 'uuid' found

Neither of the pkgconfig directories under /usr contain these .pc files. And the pc files do not show up on a wider search.

Please, what do I need to install?

There is also this :

src/generate.c:24:18: fatal error: glib.h: No such file or directory
 #include <glib.h>

however there is a glib-2.0.pc in the usr/lib/x86_64-linux-gnu/pkgconfig/ directory. Is there a misconfiguration?

Thanks

0
2

After taking

https://github.com/CanonicalLtd/netplan.git

Need to install :

libyaml-dev 
libc6-dev
libglib2.0-dev
pandoc
uuid-dev

Thanks to @dsstorefile and @user996142

To run netplan will require :

pip3 install pyyaml

For Debian 10, need also

pip3 install netifaces

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.