0

Recently I did an update and which seemed to contained an horrendous amount of bugs. After fixing most of these now i a faced with pacman telling linux 4.16.2-2 is being used. However uname is reporting linux 4.15.17-1.

I have obviously tried rebooting and updating grub but the image is nowhere to be found.

edit: Also mkinitcpio seems to only see the old kernel too.

closed as unclear what you're asking by jasonwryan, Romeo Ninov, Rui F Ribeiro, telcoM, Krinkle Apr 22 '18 at 0:56

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • When rebooting after a kernel upgrade, you can select the kernel to boot into (new or old) in the Bio bootup, its called the grub boot menu. Do you see the two versions there, and if so, which version is default? – Mark Shine Apr 19 '18 at 13:49
  • Nope. As I said the image is not on /boot so when updating grub it doesn't add the listing! – luke Apr 19 '18 at 15:54
1

I think i may have solved it.

For some reason when installing the linux package, pacman reports it is reinstalling linux416-4.16.2-2 at the beginning but the logs show from mkinitcpi 4.15.17-1 is installing. But when specifically selecting linux416-4.16.2-2 it shows it installing for the first time and logs seem correct.

This is very weird they must be an issue with the package. Its even stranger that pacman -Syy still did not select the new kernel either.

Going to reboot now, fingers crossed it works! edit: it works like a charm :)

Not the answer you're looking for? Browse other questions tagged or ask your own question.