1

Dell's Linux support for this printer is limited to a .ppd file that hasn't been updated since 2015, and that doesn't support the manual duplex mode that is apparently hard-coded into the printer's firmware.

To elucidate, when printing under Windows with provided drivers the user can set duplex options normally (one-sided, long-edge, short-edge), and then the printer's lcd display prompts the user to manually put the pages back into the paper tray after half the job is complete (and press the Okay button to finish the job). This suggests that the manual duplex feature is baked into the printer's firmware, as it doesn't require the user to do anything on the client computer after the initial job is sent. Driver .ppd file in the Windows driver has the expected lines about configuring a print job for duplex printing, so one would expect that the printer firmware "knows" how to handle duplex jobs despite lacking a duplexer. Linux .ppd file for E525w does not have the lines for setting duplex options, and thus by default the only duplex option available when printing under Linux is one-sided.

Just for giggles I used dos2unix to edit the Windows .ppd file and make it compatible with cups under Linux Mint (see attached file). As expected, duplex options were now available when configuring a print job. However, when a duplex job is sent to the printer from Linux, it comes out as one-sided, without the printer display prompting the user to put pages back into the tray. I also tried lp sides=two-sided-long-edge, same result. In addition to the default Windows driver, I also modified the Dell "Open Print" driver that's supposed to be widely compatible with all of Dell's Laser/LED printers with embedded print servers, same result.

Granted, manual duplex works in Windows just fine, so this is primarily an academic exercise. If I were to guess, this printer has some sort of custom flag that's sent to the print server from the Windows driver, but I don't have any way to verify. Short of reverse-engineering the firmware I don't know what else to change in the .ppd driver. I'll continue to update this question as I try more stuff, but I'm open to any other suggestions from anybody bored enough to help.

Here's the Open Print Driver (OPD), modified to work with cups

(Edit) Modified Windows ppd driver file, ditto

  • I have been struggling with printing from Linux for over 20 years and these quirks poison Linux experience all the time. Your best bet would be to have a Windows VM handy at least. I run a Linux farm with the print server being Windows after realizing that the cost of getting Linux printing to work was prohibitive. – ajeh Apr 19 '18 at 19:18
  • Under any other circumstance I may agree with you, which is why this is an academic exercise, purely for the enjoyment of those who take a perverse pleasure in working on stuff that will likely never work ;-) – Mister_Vulcan Apr 20 '18 at 0:29
  • Understood! But when this drives you nuts, like it did me when we could not get a mail merge from Libre Office to print right no matter what, and Acrobat Reader to print correct orientation no matter what, etc, etc, and those immediately printed correctly from Windows XP, you'll see the light :) – ajeh Apr 20 '18 at 14:05
1

Welp, that didn't take long for me to give up. Some goofing around led me to the following conclusions: PS driver does not support manual duplex where the printer display prompts you, PCL v4 driver in Windows does. Dell doesn't offer those drivers in Linux flavor, and I don't know enough about PCL drivers to attempt any conversions. Strangely, the auto-prompt manual duplex option is only available when connected to the printer over TCP/IP, and does not work over USB. Also hadn't noticed that the prompt message that shows up on the printer display has a WSD footer at the bottom, leading me to think that for some reason the manual duplex feature is implemented thru the Web Services Device API even though Windows is (supposedly) communicating with a TCP/IP port alone. Note that when adding the printer Windows automatically created a WSD port, but I couldn't find a way to enable duplex when the printer's switched to that port. Go figure.

As suggested in the comments, it was necessary to add the printer in a Windows VM client and use a sharing service to make it available to Linux clients. From the VM I added the printer to my registered Google Cloud Print printers, and then used the CUPS Cloud Print utility to add it as a CUPS-enabled printer. Google also has a cloud-print-connector tool that probably does the same thing, but, eh, the first one works fine. So now I can print manual duplex without having to walk back and forth between computer and printer all the time (yay).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.