0

I installed the EPEL tools via 'yum install epel-release' and now I cannot 'yum update' without getting "Cannot retrieve metalink for repository: epel/x86_64. Please verify its path and try again" errors.

I found a page from 2014 where the member was receiving similar errors as I.

One of the comments states to change the /etc/yum.repos.d/epel.repo to use the baseurl instead of the mirrorlist as mentioned in another page/answer.

Following the second link, the change seems simple enough but after looking at /etc/yum.repos.d/epel.repo, there are three baseurl/mirrorlist lines. I'm not sure whether to update my [epel], [epel-debuginfo], and/or [epel-source].

What is the consequence of me changing all three lines? This is a production server and I'm avoiding breaking it as I just got it setup and working.

Here is a copy of my /etc/yum.repos.d/epel.repo

[epel]
name=Extra Packages for Enterprise Linux 7 - $basearch
#baseurl=http://download.fedoraproject.org/pub/epel/7/$basearch
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-7&arch=$basearch 
failovermethod=priority 
enabled=1 
gpgcheck=1 
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7

[epel-debuginfo] 
name=Extra Packages for Enterprise Linux 7 - $basearch - Debug
#baseurl=http://download.fedoraproject.org/pub/epel/7/$basearch/debug 
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-debug-7&arch=$basearch 
failovermethod=priority 
enabled=0 
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7 
gpgcheck=1

[epel-source] 
name=Extra Packages for Enterprise Linux 7 - $basearch - Source
#baseurl=http://download.fedoraproject.org/pub/epel/7/SRPMS 
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-source-7&arch=$basearch 
failovermethod=priority 
enabled=0 
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7 
gpgcheck=1
  • Unreleated note: I blockquoted my file contents. Should i have used a different method/tag? It looks sloppy due to the URLs in the file. – TeeKay Apr 17 '18 at 22:05
  • Please state the error you are encountering in your question, not link to someone with a similar error. – Patrick Apr 17 '18 at 22:37
  • Who is the troll downvoting virtually all questions here??? – ajeh Apr 19 '18 at 19:04
0

The debuginfo and source repositories are both disabled (enabled=0), so there won't be any difference between changing just the epel repo or changing all three. That said, you should probably update all EPEL repository mirrorlists/urls when you update one, in case you ever need to enable any of those repos.

  • I modified all three lines and was able to 'yum install htop' without errors. After success, I installed 'ncdu' but it had a network error but an hour later it was fine. – TeeKay Apr 18 '18 at 16:20
  • It sounds like your network connection or ISP is having problems. – ajeh Apr 19 '18 at 19:04
  • The above fix allowed me to download some EPEL packages but the experience was intermittent. Ultimately, I also determined an exemption needed to be made in our firewall. Our firewall performs SSL Decryption (deliberate man-in-the-middle attacks against internal traffic) to view SSL (HTTPS) traffic. Once I bypassed SSL decryption for download.fedoraproject.org, I have not received any issues. The specific package which forced me down the firewall route was fail2ban. Fun task of the day: “nslookup download.fedoraproject.org” for a fun surprise. Makes me love Red Hat/Fedora/CentOS more! – TeeKay Apr 23 '18 at 18:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.