4

What do I need to run Java web applications on firefox with my 64bits fedora 17? I can't pass this test but I have installed the x64 rpm from there. What is missing?

Additional note: I tried to follow these instructions (linking the libnpjp2.so) but then the JRE test crashed firefox.

3

Thanks to this page, I got the solution.

Using the JRE x64 rpm mentioned in the question, without icedtea plugin, all you need to do is linking the JRE library to firefox this way :

ln -s /usr/java/jre1.7.0_05/lib/amd64/libnpjp2.so ~/.mozilla/plugins/

In fact I just copied it the first time this is why it crashed. After that you can verify the plugin is installed in firefox by typing in the url :

about:plugins

And Java(TM) Plug-in 1.x will show up, no need to restart firefox.

0

Try to use icedtea plugin.
You installed java on your system, but you probably don't have the needed plugin in firefox.
In arch that plugin is icedtea, and as i can see, it also is in fedora: http://fedoraproject.org/wiki/Features/IcedTea

  • Just installed Icedtea and I get an error with the app I tried (gaikai). It says I am running an unsupported version and I need the official one, maybe there is another way ? – B2F Jul 24 '12 at 16:55
  • Got it working now, I am adding the answer – B2F Jul 24 '12 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.