1

I am simply trying to enable tapping on my touchpad. When I move my finger over the pad, the cursor moves, but tapping does nothing.

First I opened this question because I was trying to permanently set the tapping config on startup, but after a recent update to the OS, now the synclient tapbutton1=1 command no longer works (as in it doesn't change anything and I still cannot tap to click).

I tried setting the tapbutton setting in /etc/X11/xorg.conf.d/70-synaptics.conf and rebooted, still cannot tap to click.

#/etc/X11/xorg.conf.d/70-synaptics.conf

Section "InputClass"
    Identifier "touchpad catchall"
    Driver "synaptics"
    MatchIsTouchpad "on"

    Option "TapButton1" "1"
    Option "TapButton2" "3"
    Option "TapButton3" "2"
    Option "VertEdgeScroll" "on"
    Option "VertTwoFingerScroll" "on"
    Option "HorizEdgeScroll" "on"
    Option "HorizTwoFingerScroll" "on"
    Option "CircularScrolling" "on"
    Option "CircScrollTrigger" "2"
    Option "EmulateTwoFingerMinZ" "40"
    Option "EmulateTwoFingerMinW" "8"
    Option "CoastingSpeed" "0"
    Option "FingerLow" "30"
    Option "FingerHigh" "50"
    Option "MaxTapTime" "125"

EndSection

I also removed my mouse from the usb port and rebooted, still no change.

UPDATE: Still no luck. The little progress I've made is using the modprobe command, but attempting any persistent changes yields zero results.

To ensure Synaptics is indeed the product I'm using:

root@nohupt:~# egrep -i 'synap|alps|etps|elan' /proc/bus/input/devices
N: Name="PS/2 Synaptics TouchPad"

Methods tried:

  1. modprobe command - success but not persistent

    modprobe -r psmouse
    modprobe psmouse proto=imps
    

    this leaves me with my clunky startup.sh script, not the best solution (though it works, at least).

  2. persistent modprobe config - failed

    nano /etc/modprobe.d/touchpad.conf
    

    added following line, saved and rebooted

    options psmouse proto=imps
    
  3. persistent Xserver config - failed

    nano /usr/share/X11/xorg.conf.d/70-synaptics.conf 
    

    edited the following, saved and rebooted:

    Section "InputClass"
    Identifier "touchpad catchall"
    Driver "synaptics"
    MatchIsTouchpad "on"
            Option "TapButton1" "1"
            Option "TapButton2" "3"
            Option "VertEdgeScroll" "1"
            Option "HorizEdgeScroll" "1"
    EndSection
    
  4. copied 70-synaptics.conf from usr/share to X11 config dir, saved and rebooted - failed

    cp /usr/share/X11/xorg.conf.d/70-synaptics.conf /etc/X11/xorg.conf.d/70-synaptics.conf
    
2
  • Did you get any further with this? Having the same results
    – mfaerevaag
    Dec 5 '18 at 14:32
  • @mfaerevaag I have not had time to test it further, however the fact that touchpads can record your fingerprints these days has made me think twice and now I've learned a lot of basic keyboard commands to move around if I forget to bring my mouse with me ;)
    – nohupt
    Dec 7 '18 at 22:22
1

Issue at Hand

You are reporting that you are unable to get the tapping of the touchpad functionality to work. You have verified that your touchpad is in working order and that this setting once worked until a recent update. I am understanding the issue correctly?

Solution

I will be referencing this forum post concerning getting taping on the touchpad to work with Kali Linux. I will also include a link to the Synaptics Touchpad Debian Wiki. Please read through both of these before trying any fixes. My solution will be working under the assumption that you have synaptic and all relevant touchpad drivers installed as well as a largely clean or vanilla configuration. It may help to purge your old configurations for synaptics that you are listing before beginning.

Using Modprobe

You should be able to rectify your issue by following these steps. Open terminal and run:

modprobe -r psmouse
modprobe psmouse proto=imps

Verify if this solves the issue. If so then to make the changes persistent, create a config file under /etc/modprobe.d like /etc/modprobe.d/touchpad.conf with the following contents:

options psmouse proto=imps

Alternatively you may be able to solve this issue graphically. Verify you have the synaptics packages installed properly and complete these steps:

Go into system settings > input devices > touchpad and enable touchpad clicking.

Verify if this solved your issue. However, if it does not then the next step could be to follow user FaustNostromo's steps.

Overriding Options in Xorg

This is what worked for me, I had too install xserver-xorg-input-synaptics,

sudo apt-get install xserver-xorg-input-synaptics

sudo leafpad /usr/share/X11/xorg.conf.d/70-synaptics.conf 

At the beginning of the file under Section “InputClass” add;

Option "TapButton1" "1"

It should look like this;

Section "InputClass"
Identifier "touchpad catchall"
Driver "synaptics"
MatchIsTouchpad "on"
Option "TapButton1" "1"

That's it, now after restarting the touchpad will work, the last step is optional to enable scrolling add;

Option "VertEdgeScroll" "1" 
Option "HorizEdgeScroll" "1"

Logout or reboot.

I would make sure to look over this section of the Debian Wiki closely to see what is most relevant to you. Perhaps your touchpad does not support the functionality or there is slightly different options that you want then the ones user FaustNostromo suggests.

Conclusion

Please read over all the provided links carefully. Make sure you have the correct packages installed. It may behoove you to purge the existing ones and start over. Please comment if there are any issues or questions about my post. I appreciate any constructive criticisms or edits to this post to clear up misconceptions or issues. Best of Luck!

5
  • Thanks, I actually found that same Kali post as well and so far the only thing that has worked out of all of that is manually typing in the modprobe command. Updated my question to reflect everything I've tried thus far.
    – nohupt
    Apr 18 '18 at 6:51
  • @nohupt, I notice now that you say you are using Kali 2, is there any reason you have not updated to the latest Kali? Kali 2.0 is from 2015, in 2016 they moved to a rolling release model. That could be part of the issue is that you are out of date.
    – kemotep
    Apr 18 '18 at 12:51
  • @nohupt, I have also found these posts you should check out. [1]: unix.stackexchange.com/a/241847/276845 [2]: unix.stackexchange.com/a/227616/276845
    – kemotep
    Apr 18 '18 at 16:57
  • I am on Kali Rolling, based on Kali 2: uname -a = Linux nohupt 4.15.0-kali2-amd64 #1 SMP Debian 4.15.11-1kali1 (2018-03-21) x86_64 GNU/Linux and cat /etc/issue/ = Kali GNU/Linux Rolling
    – nohupt
    Apr 19 '18 at 7:28
  • @nohupt, I see. I apologize, I have only seen it referred to as Kali 1, Kali 2 or Kali rolling. Did you get a chance to check out those other posts I linked? I can update my post to better reflect a more workable solution based off of them if they work. However if you can not get things to work, I believe the next step will be to document the issue and file a bug report with the respective dev teams.
    – kemotep
    Apr 19 '18 at 12:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.