2

With FreeBSD 11.1, using OSS, I run into the problem that if “too many” applications which produce sound output, or even “too many” tabs of YouTube in Firefox, are open, some of them will not output any sound. “too many” can be as low as two – it varies.

mpv, for example, in such cases gives the following error:

[ao/oss] Can't open audio device /dev/dsp: Device busy
[ao] Failed to initialize audio driver 'oss'
Could not open/initialize audio device -> no sound.

Do you know any way to fix this?

  • Run fstat | grep dsp to see what is using dsp and add the result See the Handbook – Claus Andersen Apr 17 '18 at 13:42
4

The command fstat | grep dsp will show which applications are keeping the device open. If you only think you are mixing from as low a number as 2 you might have some surprises there.

The default is to allow mixing of 4 - but you can easily change this using sysctl. This can be done on-the-fly as long as noone is using any channels.

Three sysctl(8) knobs are available for configuring virtual channels:

# sysctl dev.pcm.0.play.vchans=4
# sysctl dev.pcm.0.rec.vchans=4
# sysctl hw.snd.maxautovchans=4

You might then have luck by adjusting these. You can set them permanently using /etc/sysctl.conf

All of the above is from the FreeBSD Handbook section 7.2. Setting Up the Sound Card - particularly 7.2.3 and 7.2.4

  • damn what a surprise… why on earth has a PDF reader application (zathura) to use dsp? – wolf-revo-cats Apr 17 '18 at 15:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.