0

I just installed OpenBSD 6.3 on a Dell Optiplex G620 with 4 gigs of RAM, a USB keyboard and a USB mouse. The keyboard and mouse work until I log in. When the X Windows screen comes up, I get a computer icon in the bottom left corner, a graphic of my consoles in the bottom right and an xterm window in the top left corner, with the correct prompt. Then the keyboard and the mouse go dead. The cursor in the xterm window doesn’t flash.

  • The first problem is just to get access to type so I can fix the settings files.

  • The second problem is recognizing which files change drastically between login and the first console.

To clarify: this happened the first time I booted the computer after installing OpenBSD and every time since.

  • 1
    Do you run xenodm (display manager)? If yes, then boot to single mode (boot -s in boot manager prompt), mount all partitions (mount -a), and disable xenodm: rcctl disable xenodm. Then, reboot. yout will be able to log into your system console. Then, read /var/log/Xorg.0.log. Provide it here along with dmesg output. – user996142 Apr 17 '18 at 20:16
0

I just had the same problem on OpenBSD 6.3 on a Intel Kaby Lake setup that I just installed, however I seem to have solved it. I was migrating from an Ivy Bridge setup that did not have that problem, though my mouse had a problem on the old setup, which is that it kept connecting and disconnecting before I started FVWM (which is the default window manager) ... either by logging in with startx or with xenodm. It is a blingy asian-made gaming mouse with weights and DPI settings and LEDs and all that stuff (I use it because I like the double-click button).

I chose to login with xenodm during installation. The keyboard did work for me after I logged in – I could use it to move the mouse around in FVWM with ctrl+shift+arrow-key. This allows one to move the cursor over the open xterm and start typing as focus-follows-mouse position in FVWM by default (you don't have to click in the xterm to start typing... I don't know a FVWM keyboard substitute for mouse clicks). I was using the same mouse, so I decided to try a different one... I plugged in an ancient microsoft mouse which worked immediately. Curiously after I plugged it in the blingy gaming mouse started working also. I rebooted, logged in as root and used "rcctl disable xenodm" as suggested. Logged into FVWM with startx and behold... the new mouse is working. Rebooted... it's still working.

tl;dr I tried a different mouse for a few minutes and now the original mouse is working

Moar: I just found out the mouse will work when plugged into a USB 2 port and exhibits its old bug of constantly connecting then disconnecting, but not when plugged into a USB 3 port unless I enable "XHCI Hand-off" in the BIOS. I don't know exactly what the issue between this Zelotes T-90 mouse and OpenBSD is... I suspect the mouse might be requesting a USB polling rate above the default 125Hz and OpenBSD can't support it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.