1

I'm writing a script which needs to open a terminal window with a specific geometry and window title. I'm having trouble setting these with KDE konsole.

According to its help output I need to do:

  konsole -p <property=value>  

and use

  konsole --list-profile-properties

to get a list of the available properties. So I did this and I found that the properties I want to change are:

   TerminalRows, TerminalColums, TerminalCenter and tabtitle. 

Great. So I tried:

   konsole -p "TerminalRows=8"

but it didn't do anything. I've tried putting in all the properties like this but nothing seems to work. Did I mess up the syntax somehow? I should also note that I've installed console in gnome-shell in ubuntu, could that be what's giving me trouble?

  • 1
    "Configure Konsole>General>Use current window size on next startup must be disabled for these entries to work" – jordanm Apr 16 '18 at 5:08
  • Ah, can that be disabled temporarily via terminal terminal or does it have to be unchecked by user? – thebunnyrules Apr 16 '18 at 6:48
  • Not sure, I just found that by looking at the option in the GUI. – jordanm Apr 16 '18 at 13:26
  • Gnome has a command line tool called gsettings that allows you to set most of shell's prefs from the terminal. Do you know if kde has something similar? (thanks for tip by the way). – thebunnyrules Apr 16 '18 at 15:37
  • Yeah, check out kwriteconfig. I am not sure if it works for konsole settings, though. – jordanm Apr 16 '18 at 17:08
0

Unfortunately the konsole command does not recognize the complete -geometry ... specification like xterm, e.g. xterm -geometry 100x44+0-30. You have to specify the window size separately. The following command is working:

konsole -p 'TerminalColumns=100' -p 'TerminalRows=42' -geometry +0-30

The additional parameter -p 'LocalTabTitleFormat=my_tab' gives you control over the tab title.

  • Copy-pasted that -- none of the switches did anything. Until I followed jordanm's comment, "Configure Konsole>General>Use current window size on next startup must be disabled for these entries to work". – goldilocks Jul 25 at 20:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.