1

I am running Xfce4 on Linux Mint and from found strange keyboard bug - The Tab key doesn't works alongside with Shift. I can change windows using Alt+Tab and Alt+Shift+Tab, I can insert tabs in an editor by pressing the Tab key. But I cannot use Shift+Tab anywhere. For instance, in text editors to unindent text.

I checked xev and it shows KeyPress and KeyRelease event for Tab key but doesn't show anything when pressing Shift+Tab. I checked all known places where system-wide shortcuts are set to ensure that nothing assigned to that key combination - nothing.

What could it be and how else can I troubleshoot it?

2

Question unrelated to xfce4 or anything else from its dependencies. Problem was cause by XNeur keyboard layout switcher. It defines Tab for its action abbreviation completion and Shift Tab for some other actions. After clearing these bindings everything works. Without it these shortcuts ever doesn't caught by xev.

1

Maybe this could help you out:

  1. Open the Xfce Application Menu > Settings > Window Manager
  2. Click on the Keyboard Tab
  3. Clear the Switch window for same application setting

source

  • Thank you for reply, I already checked all URLs that could be found on Google. That one was already tested. Without any luck. – Alex G.P. Apr 22 '18 at 8:54
1

Issue at Hand

You report that you are unable to bind anything to Shift+Tab.

Update

Your issue does appear to be a bug. Here is a link to a potentially related bug report. According to this source, there is an issue with key bindings being set and being forgotten on reboot. There is a potential work around however. I will include links to a stack exchange post that references this bug, as well as a Linux Mint forum post that is related as well.

Newer Possible Solution

Now this is mentioned as a workaround but please try this:

Aleksander V. Dyomin (aleksanderd-e) wrote on 2014-04-19:

I found a workaround: clear before reassign!

To make a shortcut to work ok, select an action you want to reassign and click 'Clear' button until it will really empty. Sometime if there is some (hidden?)duplicates, you will still see some shortcut(the same or different), even you clicked 'Clear' button. In this case just click the button again. Since the action shortcut is really empty, just assign your custom one as usual, and it will work ok :)

In short, open the Windows Manager Keyboard settings menu, then clear out the keyboard shortcuts for the action you wish to map. Then hit clear again, and again to be absolutely sure that all entries are cleared. It appears that there can be multiple conflicting keybindings and that if there is more than one keybinding it does not show up as visible in the menu. Make sure to do it several times, then relaunch the menu and set the desired keybindings. You will have to do this for each keybinding.

If you feel this bug does not apply to you, try these steps:

  • Look for a ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml file.

  • Look for a <property name="<Shift>Tab" type="empty"> line as well as all desired keyboard properties like <property name="<Alt>Tab" type="string" value="cycle_windows_key"/> for example.

  • If any of these lines are missing or they contain the wrong values or are out of order then the desired keybinding will not work. Fixing a missing value assignment should correct the issue.

Old Potential Solution

I will be referencing this stack exchange post regarding changing global keyboard shortcuts, as well as this xfce forum post about changing shortcuts. Please read over them in their entirety before trying anything.

If user GRC's answer is not acceptable then you should try the following steps as recommended by user ToZ on the XFCE forums:

  1. Make sure that xfsettingsd is running and that you don't have another settings daemon (e.g. gnome-settings-daemon or krunner) running.
  2. Check that you haven't created any bindings with xbindkeys (look at ~/.xbindkeysrc).

Either create (or remove) the desired shortcut from ~/.xbindkeysrc and run:

killall -HUP xbindkeys

to reload the configuration. You can use the following command to search for Shift+Tab keybindings.

xfconf-query -c xfce4-keyboard-shortcuts -l -v | grep "<Shift>Tab"

Conclusion

Update

This issue appears to be a bug as outlined in this bug report. I have listed a possible work around. Again the links to relevant forum post are here and here. Please read through them in their entirety and verify if they apply.

If these newer steps do not work. Please consider filing a bug report with the respective developers. Here is a link for Linux Mint, and this is a link for XFCE. Document as much as you can of the behavior. If you find a newer solution in this process post an answer here, let me know and I will upvote you.

I would check for any rogue settings managers and either make changes there or purge them from your system. Verify that all the global menus and configuration menus have the correct settings you desire.

However if you are having issues changing application specific keybindings you will need to update your post to include what application you are using. This solution works only for global xfce settings. Please verify if you can set any kind of shortcuts first.

Please comment if you have any questions or issues with this answer. I appreciate feedback to correct any misconceptions and to improve my posts. I can update my answer if you let us know if this is an XFCE or application specific issue.

Best of Luck!

  • Thank you for so explanatory post. I cheched - I have not any settings manager except xfsettingd running. Also I event have no ~/.xbindkeysrc file. Issue is system-wide. For instance, if I open LibreOffice Writer and open any dialog window I can switch between controlb by pressib Tab but cannot go to previous control (usually Shift+Tab used for this). xconf-query also doesn't gave any meaningful output - just informs that I have <Alt><Shift>Tab key bound to reverse windows switch. – Alex G.P. Apr 24 '18 at 4:27
  • @AlexG.P., I have updated my answer. Please check to see if these possible fixes apply to you. – kemotep Apr 24 '18 at 14:34
  • unfortunately it does not works too. Issue is not related that i unable to bind anything to Shift + Tab. More exact: this shortcut does nto work (i.e. does not recognized by WM) despite of fact is anything bound to this shortcut or no. Example: run xev, press Tab, see that keyboard event was caugh. Press Shit+Tab - see nothing in xev console. – Alex G.P. Apr 25 '18 at 12:09
  • @AlexG.P. So there is no conflict with the shortcut it does not get registered by xev. Please check this post out The poster there mentions evtest as a better utility for checking multiple or special key inputs. You may also need to find new or different drivers for your keyboard. Barring that, I would suggest you file a bug report with the respective developers. – kemotep Apr 25 '18 at 13:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.