0

I am running High Sierra in a VM through VirtualBox. I recently increased the size of my vdi and in order for my VM to make use of the increase, I tried to use GParted to extend my partition size. However, this is not working. enter image description here enter image description here

The second picture is when I moved the sda3 partition over to the right so that I could extend my sda2 partition. It does not allow me to resize sda2 to anything larger than the current size. Why am I not able to use the unallocated space to extend sda2?

enter image description here

Tried committing the move for sda3 but it won't let me and I get an error. Tried committing the move of sda3 but get an error

migrated from apple.stackexchange.com Apr 14 '18 at 11:02

This question came from our site for power users of Apple hardware and software.

  • 1
    I'm voting to close this question as off-topic because it‘s not about using Apple products as described in the FAQ – nohillside Apr 14 '18 at 5:17
  • Where is more appropriate? – Jumpman Apr 14 '18 at 6:23
  • That‘s Linux, right? I can migrate it to Unix&Linux for you – nohillside Apr 14 '18 at 9:30
  • What do you mean by not being able to use the un-allocated space? What error or warning did you get? For us to get a clearer picture of how your partitions are laid out, post a screenshot of running fdisk -l /dev/sda – Emmanuel Rosa Apr 15 '18 at 1:07
  • @EmmanuelRosa Added the screenshot with the details. I don't get any warning or errors. I'm just unable to drag sda2 to make use of the unallocated space next to it. I can't resize it by typing in the size either. – Jumpman Apr 15 '18 at 4:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.