4

I updated my ArchLinux box earlier this week and it has started going to sleep when nobody is logged in locally. I want to access this box remotely and continue running Cron jobs overnight, which this sleep currently breaks.

https://pastebin.com/qG4gHmrY contains journal entries around the time the system last went to sleep

I disabled auto-suspend in Gnome yesterday after noticing GDM displaying a message saying it was going to do this, but it didn't appear to have any effect.

Any suggestions would be appreciated! I've been struggling to know what details would be relevant/useful to help diagnose this, please let me know…

Things I've checked:

  • Config in /etc/systemd/logind.conf has #IdleAction=ignore
  • Lots of seaching for "sleep", "hibernate", "suspend" in /etc and journalctl output

Most search results seem to be people interested in making it work. It works amazingly well (so well I didn't notice it had been enabled at all), I think I just want to turn it off!

  • I know you think the trigger was software and not hardware, but have you checked your BIOS to confirm no setting there has enabled auto-suspend? – Mark Stosberg Apr 13 '18 at 13:46
  • how would the BIOS have enough knowledge to control this? the system doesn't go to sleep when I'm logged in and leave it alone for an hour or two – Sam Mason Apr 13 '18 at 13:55
  • I don't always know how BIOS interact with the OS, but I do know that sometimes BIOS contains suspend-related options. For example, some BIOS allows you to choose "sleep" vs "hibernate", or disable hibernate. – Mark Stosberg Apr 13 '18 at 18:54
4

I asked about this on the arch linux IRC channel, and had the following response:

<Namarrgon> smason: it's a bug in gdm
<Namarrgon> when you disabl automatic suspend in gnome it doesn't affect gdm itself

based on this, I found a relevant looking exchange: https://unix.stackexchange.com/a/361275/90376

which I altered to the following commands:

sudo machinectl shell gdm@ /bin/bash
export GSETTINGS_BACKEND=dconf
gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout 0

This has now been running for a couple of days and my cron and other background jobs remain running over night.

  • Sweet! I use an Arch box (Manjaro to be exact) as a server, when not using it as a desktop computer, and this bug was killing remote access and my workflows. Thank you for digging through it! Do you have any idea why the export GSETTINGS_BACKEND=dconf is required? Manjaro comes with dconf editor which has the sleep-inactive-ac-timeout option set by default to 1200. I'm just wondering if that won't work out of the box... – Kartik Oct 8 '18 at 2:47
  • 1
    It's just telling gsettings to save the settings somewhere that will get looked up later… the machinectl shell command didn't ensure this was set up correctly for me, so hence needing it – Sam Mason Oct 8 '18 at 8:42

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.