This started after some kernel trouble that I left alone for a while. I had miscompiled a kernel then tried to re-compile it and started to organize a list of boot options in grub for differently configured kernels and vbox threw a fit so I left the computer alone for a while.

Booting it back up now I get 1 of 2 different error messages.

grub loading stage 1.5
error 17/18


grub loading stagerror

I'm running Gentoo 64bit and I have been updating it through a chroot environment

This is on a 2TB drive that I have 1.08TB used that I can not back up though I have a tar image of the root

partition layout is as fallows

1    50GB    EXT4    /        10GB   Used    40GB  Free
2    1950GB  EXT4    /home    1.08TB Used    800GB Free
  • You appear to be using legacy grub, which has been unmaintained and deprecated for several years. You should upgrade to grub2. – psusi Jul 23 '12 at 18:10
  • 1
    gentoo has it's own maintained version. They are working on moving to 2.00 but as of now gentoo's stable repo has grub .97-R14 – Joe Jul 25 '12 at 3:58

It's hard to say what exactly "vbox threw a fit" means, but according to Gentoo Grub Error Collection, error 17 is Cannot mount selected partition, and error 18 is Selected cylinder exceeds max supported by BIOS. Looking at How to fix GNU Grub error 17?, it looks like this can be caused by a broken GRUB installation, which isn't entirely unreasonable if you have been working in a chroot environment. grub loading stagerror (or something similar) also would seem to point in such a direction.

The first thing that I would try is to simply reinstall GRUB. Boot with a rescue CD, mount your root partition, chroot into it, and then reinstall the boot loader. That last part might be as simple as:

# grub
grub> root (hd0,0)
grub> setup (hd0)
grub> exit

Make sure that the device specifications are correct.

  • have done that but it almost seems like it is not installing to the mbr or something. I'm running puppy linux now as a temp solution but I can not chroot from here as puppy is 32bit and my gentoo is 64bit. – Joe Jul 23 '12 at 12:20
  • going to boot backtrack and I'll respond after I try this. When I tried before to reinstall grub I just used the auto install ( grub-install ) but maybe this is not working right because of the chroot running on the ubuntu kernel – Joe Jul 23 '12 at 12:29
  • vbox throwing a fit is the fact that you have to have it recompile it's modules from the new kernel source and you have to do it before there is a new kernel update or get ready to recompile vbox/copy the binary portion for usb support – Joe Jul 23 '12 at 12:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.