0

I installed Qubes a few days ago to try it, and so far it was okay, with the built-in templates and stuff the current version (4.0) is more or less stable and usable.

My problems began when I decided to setup a custom templateVM (kali) to experience the process and see how it works. I can tell that the qvm creation and the os install was smooth except one thing. I couldn't get networking on my new template. I've did my research on the topic and went through this article multiple times, but still I'm definitely missing something.

I checked the IP and a gateway address in Qube Manager, and configured the template manually to use those addresses, however still no Internet. I'm able to ping the gateway, but that is all I can do from that VM.

I event configured it to connect directly to net-vm, thought bypassing firewall might solve it, but didn't helped.

Anyone could kick me to the right direction what to look for or what to double check?

0

Update: I had a similar problem with fedora-28-minimal, as I described below I managed to make it work, but only temporarily. But with the standard template fedora-28 the network was configured automatically after I setup the networking in Qubes Setting.

Update: This below worked until I rebooted the VM. Now I get "Error: Nexthop has invalid gateway" when adding the route.

I think I had a similar problem but for me setting up the networking manually worked: ip addr add x.x.x.x/24 dev eth0 ip route add default via y.y.y.y dev eth0

where x.x.x.x is the qube IP address and y.y.y.y is the Gateway address taken from the qube settings in Qube Manager (section Networking)

Then I also had to edit the /etc/resolve.conf file and put there the content I found in a different AppVM.

And then I could ping public servers.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.