15

When connecting to my development server via ssh, I can forward remote ports to local ports via:

ssh my-user@example.com -L 5432:localhost:5432

However I'd rather use mosh because my connection tends to drop. I tried extending my usual mosh command (that works) with the --ssh parameter:

mosh --ssh "ssh -L 5432:localhost:5432" my-user@example.com

Which gets me connected without error - but doesn't do anything for my ports.

Is there a way to make port forwarding work when connecting via mosh?

3 Answers 3

17

I found an open issue for this exact feature at Mosh's GitHub. And an open bounty at bountysource currently at $616.

So it looks like it's not possible yet.

--

As a workaround for my SSH disconnect issue I added the following lines to my server's /etc/ssh/sshd_config:

ClientAliveInterval 60  # send null packet every x seconds to clients
ClientAliveCountMax 720  # time them out after doing so y times

Followed by a restart of the SSH daemon and a re-login via SSH.

sudo /etc/init.d/ssh restart
sudo service ssh restart
sudo systemctl restart ssh

This of course doesn't help with situations like changing cell towers on mobile connections like mosh does.

0

This feature is not yet supported. However, there is always the workaround that you can run an SSH session in parallel.

2
  • 1
    Welcome to the site, and thank you for your contribution. You may want to edit your post to address the OPs issue "I'd rather use mosh because my connection tends to drop." which was the reason not to use SSH port forwarding in the first place.
    – AdminBee
    May 28, 2021 at 14:42
  • Any updates on this please? Aug 6, 2021 at 11:22
0

Mosh opens an ssh session to setup the initial connection. Keeping that open would be a good way to maintain port forwarding while still using mosh for interaction. I've tried setting this up without any success:

mosh --ssh="ssh -fN" # hangs forever
mosh --ssh="ssh -f" # ssh gets terminated

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.