0

I have installed ubuntu on VMware® Workstation 14 Player.

I can see the ip with ifconfig:

eth0      Link encap:Ethernet  HWaddr 00:0c:29:65:af:66  
          inet addr:192.168.223.129  Bcast:192.168.223.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fe65:af66/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:337 errors:0 dropped:0 overruns:0 frame:0
          TX packets:362 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:40108 (40.1 KB)  TX bytes:34591 (34.5 KB)
          Interrupt:19 Base address:0x2000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:686 errors:0 dropped:0 overruns:0 frame:0
          TX packets:686 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:54536 (54.5 KB)  TX bytes:54536 (54.5 KB)

When I try to connect by ssh or putty It is not connecting and returning message:

ssh 192.168.223.129
ssh: connect to host 192.168.223.129 port 22: Connection refused
  • Are you sure that the sshd is installed and running? – mnille Apr 11 '18 at 5:13
4

You need to install ssh server on your ubuntu:

sudo apt-get install openssh-server

Now start and enable the debian ssh server to start at system reboot.

systemctl start ssh.service

systemctl enable ssh.service

Also run netstat command to make sure that ssh port 22 is open and running.

netstat -tulnp | grep 22

then try to access...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.